Swapped HDMI for DVI and everything broke

  • I have a two monitor set-up. 1 Acer on DVI and an Asus on HDMI. I swapped the cables and video went really bad on the Asus. Swapped them back and nothing changed, also noticed that anytime I would do ANYTHING that required ANY call the the GPU, there would be lag and stuttering. Diablo would load, but take forever, and when I finally got in a game, I would try to load a waypoint, only for it to take forever again, then the server would boot me as soon as I loaded into the waypoint.

    Rebooted, nothing. Unplugged BOTH cables, plugged them back in, and there is a slight improvement. However, playing Diablo, it seems like all the graphic resources are being loaded for the first time when they show up on screen. The game stutters with minor items, freezes for a short time with larger items, and occasionally locks up for a while during graphic heavy events. Mouse still works, hell, everything still works while the game is frozen.

    Any ideas?
  • Howdy!

    Can you try the following:
    - Goto your Documents folder -> Diablo III folder -> Delete the: D3Prefs.txt file. This will reset the game back to default settings.

    - Make sure your display drivers are updated.

    Can you post up your Dxdiag within code blocks? This may be related to how your GPU is handling performance now that you have two monitors plugged in, seeing your dxdiag will help us give the proper troubleshooting.

    Thank you!
  • To put your DxDiag in a code block, copy/paste the entire file into your next post, highlight all of it within the post box, then click the </> button.
  • Howdy!

    Step 1) Update your driver to the latest version Here.
    - Recommend you do a fresh install.
    - When you get to the Install Options selection pick: Custom (Advanced) -> Next -> Check: Perform a clean installation. Finish the install and restart the computer.

    Step 2) Set your Operating System and Nvidia Power Settings to high performance:

    - Press (Windows key - Q) The search menu will pop up, type in: Power Options
    Hit Enter. Select: Show Additional Plans -> Select: High Performance. Exit the window.

    - Right click on your Desktop -> NVIDIA Control Panel -> Manage 3D Settings -> Under the Global Settings tab -> Select: Power Management mode -> Prefer Maximum Performance. Check: Multi-display/Mixed-GPU Acceleration: Make sure this is set to: Multiple Display Performance Mode. Select Apply -> Exit the window. Restart the computer so these settings kick in properly.

    Thank you!