FPS Drops when laptop is plugged in.

  • I initially thought I was one of the many with the 1.02 patch messing up the game where my FPS drops to 5-10 during battle and idles at 15-20 in town.

    This morning however, I turned on my laptop without my charger plugged in and ran D3 to find that my FPS is at a stable 50-60. When I plug in my charger however, it drops IMMEDIATELY to 15-20.

    Anyone else have a problem with their charger? I've tried different outlets but to no avail. I've searched google to see if anyone else has had this problem but couldn't find anything. Should I just replace my charger?

    Help please!
  • We typically ask that if you are experiencing an issue and there are no active posts regarding it, it is best to make a new post. (You can always link to an old post in the new one if you want for reference) I am going to go ahead and lock this one down but did want to give you a bit of advice that might help solve this.

    This issue will typically come down to one of a couple possibilities.

    First your system is likely using both an Intel and nvidia GPU. It will typically use the intel for day to day stuff and switch to the nvidia when gaming. Normally.

    Now battery power saving should disable the nvidia gpu and rely on the Intel gpu to extend battery life. (The nvidia gpu eats a lot more power than the integrated.) This is normal however in most cases you should see the opposite of what you are seeing as the integrated is not as powerful.

    It sounds like this is what is happening and that for some reason your intel gpu is performing better than the nvidia gpu.

    It could be drivers, settings or something else running on the system. Maybe there is a process that runs normally on the system that doesn't run when switched to low power mode?

    Let's make sure you have the latest drivers, proper settings and let's remove as many possible program interference issues as we can.

    For Intel go here.
    For all Nvidia Video cards go here.

    Let's reset the in game user options:
    1. Click the blue bnet icon on the bnet app.
    2. Choose settings, then game settings.
    3. Click the reset in game user options button under the correct game listing.
    4. Confirm the changes and close the window.

    If you are on Windows 10, please disable the Game DVR (Please also disable GameBar and GameMode functions if you are on the Creators Build)

    Please disable Nvidia Share. You can access this option through the Geforce Experience Desktop Application. Simply log into the application. Click on the gear symbol, scroll down to the Share Section and move the slider to off.

    Try running your system in selective startup mode.

    Finally, I would like you to temporarily uninstall (disabling the programs often causes them to clamp down even more) all security software currently on your system and then restart the computer. Test the game. Once you have completed testing I recommend putting some sort of security programs back on.