HP Switchable graphics issue

  • Hi there,

    I've got an HP dv3 2310ea laptop with an ATI 4550 Graphics Card which is switchable (the laptop also has the basic built in Intel HD graphics).

    I was able to play the beta with absolutely no problem at all - but on the full game I'm getting huge amounts of lag - even on the log in screen, which I think means its using the Intel HD graphics rather than the ATI 4550 card.

    I've read various problems about D3 and switchable graphics and all I've read seems to indicate that if you upgrade your drivers you should only be using the ones provided by HP and that the ones from ATI will nuke the switchable graphics. I've tried updating my BIOS but that hasn't done the trick.

    Can anyone suggest anything to try as I don't why see the beta would be fine but the full game wouldn't work.

    Thanks.
  • Hey, ziplock9000!

    This is an extremely old post, so I will be locking it. But to make sure the game is running on the proper card, please follow the steps below. If you still have an issue after following the steps, please make a brand new post.

    Nvidia:

    Settings can be adjusted using the Nvidia Control Panel

    1. Right click on the desktop and select the Nvidia Control Panel.
    2. Click on "Manage 3D Settings" located in the left window pane.
    3. Click on the "Program Settings" tab.
    4. Click on "Add", browse to the game folder, and select the game exe file
    5. Select "High Performance Nvidia Processor" from the "Select the preferred graphics processor" drop down menu. If the High Performance Nvidia Processor setting is not listed jump down to the next steps.
    6. Click on "Apply" and close the Nvidia Control Panel.
    ***repeat the same steps for the 64 bit client as well if available***
    Next:
    1. Right click on the desktop and select the Nvidia Control Panel.
    2. Click on "Configure Surrond, PhysX" located in the left window panel
    3. Under PhysX setting change the drop down to the Nvidia card.
    4. Click on "Apply" and close the Nvidia Control Panel.
    5. Restart your computer.

    AMD:

    Official instructions can be found here:
    https://community.amd.com/docs/DOC-1581

    From Radeon Settings/Catalyst Control Center:

    1. Go to Graphics -> PowerPlay - Set Plugged In and Battery to Maximum Performance. Click Apply.
    2. If applicable to your graphics card, go to Graphics -> 3D and move the slider across to Performance so it is set for Optimal Performance. Click Apply. NOTE: This function might not be available on all ATI models.
    3. Re-start your computer.