Green screen when running at 4k resolution

  • Whenever I try to run Diablo 3 at 4k resolution at anything higher than 30hz, my entire screen turns green and everything looks all skewed. It's really ruining my gaming experience in this game. I have tried 50hz, 59hz, and 60hz and they all have the same problem. I am not experiencing this in any other games. I'm running a GTX 1060 6gb card on the latest drivers (372.70). I'm running Windows 10 x64 with all the latest updates installed. I have also installed all the latest patches for Diablo 3.

    Here is a link to a screenshot of the problem:

    https://postimg.org/image/43sve8hzl/

    I am running at 4:2:0 chroma if that makes any difference.

    I have contacted nVidia about this and I submitted a driver bug report. I don't know if this problem is at Blizzard's end or if it's an nVidia specific problem.

    I would really appreciate it if you guys could look into this! Thanks!
  • I have the same problem at home on a 55" 2015 Vizio M series UHDTV running on an EVGA GTX 980 Ti Hybrid (AIO water cooled).

    It's got nothing to do with the game though, It happens in Windows just powering up, mostly when everything's cold. If I let it sit powered up eventually it'll be able to go to 60Hz refresh and from then on it's fine, but I got tired of the hassle and just went to using a 1080p res instead which is rock solid at 60Hz, no support for 120.

    For me, it's either the Vizio or my GTX 980 Ti, it's got nothing to do with game software.