Diablo 3 Beta System Requirements

  • Diablo III Beta System Requirements

      Mac Minimum System Requirements:
    • Mac® OS X 10.6.8, 10.7.X (Latest Version)
    • Intel® Core 2 Duo
    • NVIDIA® GeForce® 8600M GT or ATI Radeon™ HD 2600 or better
    • 12 GB available HD space
    • 2 GB system RAM
    • DVD-ROM drive
    • Broadband Internet connection**
    • 1024x768 minimum display resolution
      (**Note: Be advised that some wireless connections do not meet the minimums required to be a true Broadband Internet connection. Wireless results may vary.)

      Mac Recommended System Specifications
    • Mac® OS X 10.7.X (Latest Version)
    • Intel® Core 2 Duo
    • 2 GB of system RAM or greater
    • NVIDIA® GeForce® GT 330M or ATI Radeon™ HD 4670 or better
      Unsupported
      (If you have any of these then your system is not supported)
    • Any PowerPC processor
    • Intel GMA 950
    • Intel GMA X3100
    • NVidia GeForce 7300 GT
    • NVidia GeForce 7600 GT
    • NVidia Quadro 4500
    • ATI X1600
    • ATI X1900
    • ATI 2400 XT
    • Hackintosh
  • Model Name: MacBook Pro
    Model Identifier: MacBookPro8,2
    Processor Name: Intel Core i7
    Processor Speed: 2.2 GHz
    Number of Processors: 1
    Total Number of Cores: 4
    L2 Cache (per Core): 256 KB
    L3 Cache: 6 MB
    Memory: 8 GB

    running 10.7.2 should work right?


    Your machine is above the beta system requirements, so it should work fine.
    ________________________________________________
    Mac Tech Support for Baaaaahlizzard Entertainment || Fri-Tue 1:45 pm - 10:45 pm CST
    http://www.surveymk.com/s/RF8K3KG ---- Rate my Baaaaalue Posts. Haala at your sheep!
    Mac Blue will make you JUMP JUMP
    Tony Mac will make you JUMP JUMP
    Blue posts will make you JUMP JUMP
  • Do the Woodcrest Xeon processors in the first generation Mac Pro (like my Xeon 5160) meet the "Core 2 Duo" requirement? I'm pretty sure that they're architecturally similar to the Core 2 Duo processors but I'd like to be sure.


    Hi Lynseko,

    I just wanted to confirm this for you. Yes the Woodcrest Xeon processors do meet the Core 2 Duo requirements. I've confirmed this with Padim.
    ________________________________________________
    Mac Tech Support for Baaaaahlizzard Entertainment || Fri-Tue 1:45 pm - 10:45 pm CST
    http://www.surveymk.com/s/RF8K3KG <---- Rate my Baaaaalue Posts. How's this sheep doing?
    It's the return of the Mac, you know that i'll be back, oh oh ohhhh!!
    Everyone to the farm, take the farm!
    This is AV, sir...
  • I think it would be better if we show you what is also NOT supported, so you can get an idea as well.

    GMA 950
    GMA X3100
    nVidia 7300/7600
    ATI x1600/1900
    nVidia Quadro FX 4500


    ________________________________________________
    Klint P
    Mac Tech Support for Blizzard Entertainment || Mon - Fri 1:45pm - 10:45pm CST
    If you can't find it here, contact a rep direct :http://us.blizzard.com/en-us/company/about/contact.html
    https://www.surveymk.com/s/TKL88F8 <---- Rate my Blue post here...
    The Restrooms are for paying customers only!
  • Just as an update to this, for the OS X requirements, you should always be at the latest version of your OS X.

    10.6.x
    10.6.8 is the latest version
    10.7.x
    10.7.2 is the latest version
    These system requirements will be on a sliding basis, so when 10.7.3 gets released, then this will be the latest requirement.

    To quote the great S4d1k on why this is:
    If you do not have the last version of your OS X, you MUST install the latest MacOS X update.
    Most of our crash reports come from people with old versions of the OS. If you're crashing and doesn't use the latest free update available to you then you can only blame yourself.

    Just to add a bit on what S4d1k is saying, Apple releases important updates that can affect the way our game runs and drivers for your video cards. Not updating can cause such issues as crashing, graphical errors, connection, other weird issues.
    ________________________________________________
    Mac Tech Support for Baaaaahlizzard Entertainment || Fri-Tue 1:45 pm - 10:45 pm CST
    http://www.surveymk.com/s/RF8K3KG ---- Rate my Baaaaalue Posts. How's this sheep doing?
    Dedicated to making your Mac/Blizzard Experience an awesome one!
    Knowing others is intelligence; knowing yourself is true wisdom.-- Lao Tzu
  • I'll pass on this feedback about the Intel HD 3000 and the 9400m.

    I do know that the 9400m has low shader capabilities, which is why it may have some issues with D3.

    Remember D3 is a newer game than SC2/WoW, so graphics performance may not be teh same as these games, but I will see what I can find out about it.
    ________________________________________________
    Mac Tech Support for Baaaaahlizzard Entertainment || Sunday to Thursday 11:00 am - 8:00 pm CST
    http://www.surveymk.com/s/RF8K3KG ---- Rate my Baaaaalue Posts. How's this sheep doing?
    The Mechanical sheep formerly known as as TonyM!
    If at first you don't succeed... call it Version 1.0..
  • This happens due to 3rd party unzip utilities mainly. Try using the OS X's native Archive Utility to unzip the file.
      1. Locate the appropriate Zip file.
      2. Secondary (Right) click and select "Open using Archive Utility"
      3. The file will unzip using the proper permissions and run.

    ________________________________________________
    Mac Tech Support for Baaaaahlizzard Entertainment
    Not finding what you need here? Contact a rep direct! http://us.battle.net/support/en/article/contact

    Pfft! Secret doors, who needs 'em? What do I care about secret doors?... and the unparalleled delights they keep hidden from the world!
  • This thread is for inquires about the system requirements. If you're having or need to report performance reports, please post in our performance thread here: http://us.battle.net/d3/en/forum/topic/4015203511
    ________________________________________________
    Mac Tech Support for Baaaaahlizzard Entertainment
    Not finding what you need here? Contact a rep direct! http://us.battle.net/support/en/article/contact
    Mac Blue will make you JUMP JUMP
    Machkhan will make you JUMP JUMP
    Blue posts will make you JUMP JUMP
  • 03/17/2012 08:21 PMPosted by D3BETA
    I have an iMac that meets the requirements for the game, but my ATI Radeon HD 2400, which is now listed on the website as a supported video card, is rejected as unsupported when I try to launch the beta. I'm running 10.6.8, Intel Core 2 Duo 2GHz, 4 GB RAM.

    This is unsupported for Macs. The video card list there is for PC.

    It's best to check the sticky here to review what is supported vs unsupported: http://us.battle.net/d3/en/forum/topic/3123365742
    ________________________________________________
    Mac Tech Support for Baaaaahlizzard Entertainment
    Not finding what you need here? Contact a rep direct! http://us.battle.net/support/en/article/contact
    Mac Blue will make you JUMP JUMP
    Machkhan will make you JUMP JUMP
    Blue posts will make you JUMP JUMP
  • 05/08/2012 11:51 AMPosted by Uffa
    My wife's macbook has 2 gigs of ram and i'm thinking of upgrading it to 4 gigs. I noticed that under "recommended system requirements" it's 2 gigs (unchanged from minimum) unlike SC2 and WOW recommended is 4 gigs. I'm wondering if this a typo or it's just that D3 won't benefit from 4 gigs of RAM?

    This is a good question. I will run this buy our team for review to make sure.
    ________________________________________________
    Mac Tech Support for Baaaaahlizzard Entertainment | Sun-Thur

    I'm not big on boasting, but you might have to take a victory lap.