Frame rate drop since patch 16

  • I used to be able to play prior to this patch at default settings with all characters and the graphics were awesome barely any lag. Now since patch 16 it's not even playable unless I disable everything in which case the graphics are horrible and I still only get 20 FPS.

    My rig is capable of running wow at 60FPS so I should be able to run this at 60 FPS too. I have played with all the settings can't even get it above 30 FPS. Here is my rig.

    Operating System: Windows 7 Home Premium 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.120305-1505)
    System Manufacturer: TOSHIBA
    System Model: Satellite L770
    BIOS: BIOS Date: 06/28/11 17:51:37 Ver: 04.06.03
    Processor: Intel(R) Core(TM) i3-2310M CPU @ 2.10GHz (4 CPUs), ~2.1GHz
    Memory: 8192MB RAM
    Available OS Memory: 8104MB RAM
    Page File: 2771MB used, 13434MB available
    DirectX Version: DirectX 11

    Display Devices
    Card name: Intel(R) HD Graphics Family
    Manufacturer: Intel Corporation
    Chip type: Intel(R) HD Graphics Family
    DAC type: Internal
    Device Key: Enum\PCI\VEN_8086&DEV_0116&SUBSYS_FC601179&REV_09
    Display Memory: 1696 MB
    Dedicated Memory: 64 MB
    Shared Memory: 1632 MB
    Current Mode: 1600 x 900 (32 bit) (60Hz)
    Monitor Name: Generic PnP Monitor
    Monitor Model: unknown
    Monitor Id: LGD02F7
    Native Mode: 1600 x 900(p) (59.978Hz)
    Output Type: Internal
  • Can you please upload a video to YouTube showing your performance? Please also show your FPS by using CTRL+R
  • 04/12/2012 07:07 AMPosted by Rytek
    Why is a video of our decreased performance uploaded to youtube even needed?


    Because myself, nor my team, can reproduce this on our machines at work. My Beta is playing fine at about 50 frames per second on a GTS 250 card.
  • Vasadan - any ETA for the patch that fixes the Mac framerate? Brand new Macs are running the game around 10fps post patch 16... the beta is basically worthless now.

    I've only seen additional discontented Mac users pile on to my thread over at incgamers.


    Also, the Mac issue is a different bug that is already mentioned in the Known Issues sticky. I have no ETAs on that fix.
  • Thanks guys, we'll keep looking into this. Good to see that not everyone has this issue as well since some of you say you're at 60 FPS.

    Just a reminder, the sooner you get some videos for my team uploaded, the faster I can help out :)
  • Hey guys,

    Locking this thread as we are now in Beta Patch 17. If you are still having major FPS issues, please make a new thread :)