Mavericks

  • hey just curious will diablo 3 be fully compatible with OS X Mavericks?
  • Locking this thread since it's years old. Our System Requirements for Diablo III can be found Here. The lowest OS X supported is 10.11 but we strongly recommend to keep the OS X updated to the latest version. Any feedback about the game's system requirements should be posted on our General Forums for our developers to see.

    Thank you.