Diablo 3 d3d error

  • Diablo III was unable to initialize D3D. Click ok to retry.

    Seeing this error when I try and launch the game. Click retry over and over with no luck. I have seen posts to update drivers and such. Tried everything with no luck.
    Windows 10 Pro 1709 64bit
    Monitor- 27" Acer S271HL 1080p w/hdmi
    GPU is GTX 1080 FTW 8gb gddr5 with most current drivers installed (388.31)\
    I7 7700K processor @4.8ghz
    16gb DDR4 Ram @3200mhz

    I have tried booting in 32bit mode and 64bit with no luck. Updated all drivers and deleted and re-downloaded D3

    Overwatch functions with no issues. Steam and Uplay games work as well.

    Any thoughts?
  • Hey BrandoHusky,

    Thank you for letting us know what you already tried. There are several things that could cause the "Unable to initialize D3D" error. I do have some other steps to try that I have seen help with this error.

    • To be on the safe side make sure Windows is up to date.

    • Delete these Blizzard App files here and here.

    Disable the Windows 10 Game DVR

    • If the D3D error still happens, post a DxDiag and Diablo III Error Logs. Paste the DXdiag and Diablo III Error Logs into the post, select and highlight everything you just pasted, and hit the "code" button (</>). That'll make the information much more readable.
  • BrandoHusky Thank you for posting the DxDiag. I would like you next to reset the Diablo III setting and then try a selective startup. If that does not help, please post a Diablo III Error Logs.

    • Reset In-Game Options.
      1) Select the game in the Blizzard app and click Options .
      2) Click Game Settings.
      3) Click on Reset In-Game Options.
      4) Click Done and launch the game normally.

    • Run the computer in a selective startup mode.

    Eangarra The files show Diablo III installed on an external USB drive. External drives can cause issues for the games. See if uninstalling Diablo III and installing on the internal hard drive makes a difference.