"Necromancer campaign is not currently available" on beta account

  • I was able to purchase the necromancer and create a necromancer character, but the "Start Game" button is grayed out. When I hover the cursor over it, it says "Necromancer campaign is not currently available"
  • nuclandsux,

    I believe the Necromancer is still not available due to maintenance.

  • Arminus,

    There's no point in opening a support ticket as Customer Support isn't able to flag accounts for forum access. That's done in batches by the developers. You'll need to wait as they're submitted and processed I'm afraid.
  • I'm locking this thread as it is off topic for the Technical Support forum which is for the Live Game only. I'd recommend anyone that doesn't have access to the Necromancer beta forums but has access to the beta itself to try the following troubleshooting:

    Step 1) Reset your Blizzard account password to refresh your cache on the server's backend.
    Step 2) After the password reset, clear your web browser's history, cookies and cache then attempt to log into the Diablo forums again to check for access. If the issue continues start a post about this on our Bug Report forums Here.
    Step 3) Make sure to note within the Bug Report forum post that you have tried the troubleshooting above, and have access to the beta. This way we can look into what is going wrong with flagging and fix it.

    All other beta related issues need to be posted on the Beta forums: Beta General Feedback or Beta Bug Report.

    For anyone just generally trying to collect the latest information on the beta for more information on the Necromancer, check out fan sites like Diablofans.com.

    Thank you!