Only Resolution option is 3200 x 1800 - Can't lower

  • Hi there,

    I received my Dell XPS 13 inch Laptop today with 4k screen with a native resolution of 3200 x1800. I Installed Diablo 3 and went to lower the resolution first thing as I knew the laptop wouldn't play the game well at 3200 x 1800 even the menu was lagging badly, however found that I can not select any other resolution apart from the native option. If I change my screen resolution in windows, and then launch the game, the game still launches in 3200 x 1800 and I am still unable to select any other resolution, I only have two options: 3200 x 1800 (49) and 3200 x 1800 (60). I've tried to edit the resolution in D3prefs, but it has no effect. Any help would be very much appreciated, thanks!
  • Heyo!

    Read over this and wanted to check what display modes you've tried. If you're trying to get the game to match your desktops resolution then you'll want to try windowed\windowed (fullscreen).

    Apart from that we can try running the game with the 32 bit client which is going to switch the game from DirectX 11 to DirectX 9: