Unsupported video cards

  • List of unsupported video cards:

    Intel GMA 950Intel GMA X3100ATI Radeon X1600ATI Radeon X1900NVidia Geforce 7300NVidia Geforce 7600NVidia Quadro FX4500
    Note: The Intel HD3000 (NOT X3100) is only working properly on 10.7.4 because of driver issues.
    Note: The ATI Radeon 2400 is below minimum requirements, so performance might be an issue.

    All other cards are supported. This means that we will do our best to fix issues, including performance, with those cards.
  • Note: The Intel HD3000(NOT X3100) is only working properly on 10.7.4 because of driver issues.


    Machkahn or S4d1k,

    Would you mind providing more detail on the quote above. Does that mean that the HD3000 shouldn't be working at all, and should not be a supported card for the game?

    Thanks, I was just a bit confused on the wording :-)


    The HD3000 is not supported under 10.6.x but it will mostly work for now. I strongly recommend that you update to 10.7.4 though. If it stops working in 10.6.x in a future patch, we will not fix the issue.
  • 05/25/2012 11:52 AMPosted by Dyslexsick
    please find support for RadeonX1600!!!!

    This won't work because the graphics card doesn't have the required features to make the game display properly. This is why the card is on the unsupported list.
  • Machkahn or S4d1k,

    Would you mind providing more detail on the quote above. Does that mean that the HD3000 shouldn't be working at all, and should not be a supported card for the game?

    Thanks, I was just a bit confused on the wording :-)

    As S4d1k stated, this is not supported due to a driver issue. It will still work, but you might see some stretchy textures. This is something that is fixed in Lion, which is why S4d1k stated it works on 10.7.4.
  • We won't add support to any of the card in the future. The reasons are lack of features and no support from Apple.

    The GeForce 9400(and all other cards) performance will be greatly improved in a future patch.
  • 06/04/2012 12:44 PMPosted by LogicalLlama
    Will there be support for the GMA X3100?

    Nope. This chipset does not have the features that the game requires to display the gamer properly.
  • If you are experience issues with the game after the patch, please create a new thread for troubleshooting. This thread here is to have discussions about supported/unsupported cards. Issues relating to FPS issues after patching should have a new thread created, or posted in the FPS cycling thread if you have the FPS cycling after patching issue.
  • 06/10/2012 12:00 AMPosted by EauDeKush420
    So, is the GMA X3100 Ever going to be accepted??


    The X3100 is not supported, and there isn't any plans to support it due to the lacking of vertex shader 3.0 or greater features. There are some threads in the forums about workarounds for this, but this isn't supported for gameplay and may cause issue that we are unable to address.
  • Dear S4d1k,

    I have the ATY, Radeonx1900, so far it works very well. My system is a Mac Pro3.1 2.8 GHz, 4 GB RAM.

    Curious to an answer to the quote if the ATY is different from the ATI and is it supported and what details do you know regarding this card.

    Thanks

    I'm not S4d1k, but I believe the card is not supported because it does not have vertex shader 3.0 or greater requirement enabled in OS X.
  • Radeon HD 4670????

    It wasn't on the list. Id like to know if it will work. Thanks!

    If it's not on the list of unsupported, it means it supported. This list was meant to have just a inclusive list of unsupported cards.