Cannot play 2 player CO-OP on XBox One

  • I have posted this elsewhere, but just in case that thread doesn't get read often, I thought I'd post it here too:

    I'm playing this on the One and I have no problem at all with the single player game or finding a 4 player multi -- however, when I and my friend, who's also playing on the One tried to have a 2 player CO-OP game - we keep on getting an error.

    We can both connect to other people's games in 4 player mode so ports aren't the problem - he however does have his NAT as Strict -- we have played other online games in co-op mode (Need for Speed: Rivals for example) and that worked fine for us both.

    Sometimes the game thinks that one of us is offline when we aren't - but that's a totally different issue.

    So, basically, one of us invites the other to join a game, the other accepts and then we get an error (no code or message) - the game simply refuses to connect us... Any ideas as to how to resolve this would be greatly appreciated.
  • Try hosting the game instead your friend. From my understanding players using Strict or Moderate NAT settings sometimes have a difficult time inviting friends to their game, but are usually able to join other players who started a game session with Open NAT.
  • Thanks for the report, Joecivic. We're doing some investigation into connection issues some Xbox users are having, and you may want to keep an eye on this thread for any updates about it.