Site Feedback

Experiencing a difficulty? Have a question or a suggestion about the site? Post them here and you can receive responses from both the forum body and the staff.
Topic Latest Post Replies Views
No Necromancer to select for Forum profile >>
by Sintan
1 1,144
Server Error When Viewing My Build >>
by z1pper
1 1,604
Name Change pls >>
by Jadax
3 1,543
Auto-scrolling is a real pain when using your editors >>
by Fullbr1nger
1 1,066
A couple of builds are gone (Error Sorry, an error occurred while processing your request.) >>
by Angry_Roleplayer
4 2,882
1016 error that some people have been getting..could be related to this site >>
by prusswan
0 1,388
Suggestion: Hellfire passive skill slot >>
by sealedinterface
2 1,997
Helms in Every Gear Slot for Build Creator? >>
by PAR5EC
9 3,995
Suggestion - Front page Stream links - disable autoplay >>
by Tagger
0 1,104
Items Dissapearing From build/site >>
by Daulphas
16 3,313
Missing Build >>
by BigJohnasty
4 1,674
Trouble adding quotes and editing comments >>
by BigJohnasty
15 2,768
Name change to match twitch account >>
by InfernalKatana
1 687
How upvotes/downvotes work? >>
by Angry_Roleplayer
9 1,886
Inna's Hold Has Bugged Stat Priority Display >>
by EnkerZan
0 843
A built-in way to bookmark builds? >>
by Angry_Roleplayer
5 1,494
Blue tracker not working ? >>
by Green
7 1,439
cannot access/change my profile/account >>
by Angry_Roleplayer
3 855
Build exists, but does not show in "My builds?" >>
by Angry_Roleplayer
3 1,021
Wizard Hat "The Swami" doesn't show up as an option for the Cube armor slot for Build maker >>
by earlwolf
4 2,222
When Build Tool will be fixed? >>
by Angry_Roleplayer
2 1,137
Is the build tool on the latest Firefox broken? >>
by tend2it
10 1,960
Cutoff date for the ptr/post-ptr(live) Builds suggestion >>
by Angry_Roleplayer
8 2,576
The Swami & Obsidian Ring >>
by Gl0wSticks
3 2,497
Builds Tool Errors (2.4.1 transition) >>
by Bagstone
23 4,436
What's the deal with spamming/doubling/multiplicating builds? >>
by Angry_Roleplayer
11 3,036
I can't create a build, Why? >>
by milio3
0 680
Pages not loading/buttons not active? >>
by oldschool_2o4f
2 638
forum links isnt working >>
by JonSchaffer
6 1,180
Site build tool: missing items >>
by khanbg
0 613