Still have the 315300 error

  • fter they fixed the database yesterday i still keep getting this error. Now its sure its not serverside problem but with my diablo. I also tried to log on friends account and same error ocurred.

    this is the report from d3debug file.

    ===== Battle.net Platform : Connect =====
    2012.03.10 20:44:43.916277200 ===== Battle.net Platform : Connect =====
    2012.03.10 20:44:43.918427600 ===== Battle.net Platform : calling Interface.Connect to Bnet beta.actual.battle.net:1119 =====
    2012.03.10 20:44:44.337595900 >>> Platform::OnConnected_Internal code=0 connId=2 address=beta.actual.battle.net port=1119
    2012.03.10 20:44:44.737594900 >>> Platform::CheckAssert_OnAPIInitialized Platform::OnAPIInitialized_Authentication_Internal code=0
    2012.03.10 20:44:44.740269500 ===== Battle.net Platform : Connected to Battle.net =====
    2012.03.10 20:44:44.742514200 ===== Battle.net Platform : Authentication.Logon [email protected] =====
    2012.03.10 20:44:44.920911300 >>> Platform::CheckAssert_OnAPIInitialized Platform::OnAPIInitialized_Challenge_Internal code=0
    2012.03.10 20:44:44.923536900 >>> Platform::CheckAssert_OnAPIInitialized Platform::OnAPIInitialized_Report_Internal code=0
    2012.03.10 20:44:46.787597800 >>> [email protected]
    BnetService::Authentication::LogonCallback code=3
    2012.03.10 20:44:46.790235600 >>> ((no hero selected)) OnlineService::BnetService::Logout
    2012.03.10 20:44:46.792435200 ---------------- ModalNotificationManager::DefaultErrorHandler : 315300 The account name or password is incorrect. Please try again. (Error 315300) ----------------
    2012.03.10 20:44:46.795134400 >>> Battle.net InterfaceListener::OnDisconnected code=3018 connId=2
    2012.03.10 20:44:46.797362700 >>> Platform::OnDisconnected_Internal connId=2
    2012.03.10 20:44:46.799521300 >>> (no hero selected) ===== Battle.net Disconnected logoutRequested=yes =====
    2012.03.10 20:44:46.801659400 ===== BnetCommon::Platform::Disconnect connectionState=0 =====
    2012.03.10 20:44:46.803838400 >>> (no hero selected) ===== Battle.net Logged Out =====


    It looks like it might be the cache problem but i dont really know how to fix it. I also reainstalled diablo today for the second time, didnt help at all.
    I use windows XP.


    So please if anyone had this problem and uses win Xp and fixed it i would appreciate your help.
  • player,

    Try deleting the C:\ProgramData\Blizzard Entertainment\Battle.net\Cache folder or renaming it instead if you'd like to maybe put it back afterwards if it doesn't help.

    ____________________________________________________________________
    Support Information Administrator

    Please feel free to contact a Support Representative directly if needed for further assistance. Contact information can be found at: http://us.blizzard.com/en-us/company/about/contact.html


  • player,

    You shouldn't be copying cached data from another user into your computer. That data is derived from what your client has accessed and cached for later use. Copying it from someone else can cause all sorts of strange issues.

    Are you sure you don't have the Cache folder I described earlier? You'll need to set the option in Windows to display hidden files and folders to see the ProgramData folder.

    ____________________________________________________________________
    Support Information Administrator

    Please feel free to contact a Support Representative directly if needed for further assistance. Contact information can be found at: http://us.blizzard.com/en-us/company/about/contact.html