Connection Issues

  • Ever since the start of this new season I've had issues with connecting to the game. I keep getting Code 3006 and when I do eventually get in game sometimes I lag like crazy while others I don't. I've played since D3 beta and never had issues until this current patch.
    I'm using a Ethernet copper internet service btw not dsl or cable or fiber.

    Looking Glass info
    <code>TRACEROUTE:
    traceroute to 184.80.232.234 (184.80.232.234), 15 hops max, 60 byte packets
    1 24.105.30.2 (24.105.30.2) 1.045 ms 1.042 ms 1.062 ms
    2 * * *
    3 137.221.66.6 (137.221.66.6) 1.353 ms 1.404 ms 1.470 ms
    4 137.221.68.72 (137.221.68.72) 1.268 ms 1.269 ms 1.270 ms
    5 137.221.68.34 (137.221.68.34) 0.948 ms 0.964 ms 1.151 ms
    6 213.248.78.166 (213.248.78.166) 1.311 ms 1.172 ms 1.236 ms
    7 dls-b21-link.telia.net (62.115.123.136) 32.056 ms 32.077 ms 32.072 ms
    8 213.248.82.238 (213.248.82.238) 31.312 ms 31.321 ms 31.324 ms
    9 xe0-2-3-0.cr02.dnvt01-co.us.windstream.net (40.136.97.125) 31.337 ms 31.357 ms 31.358 ms
    10 xe11-2-0-0.pe06.txrk01-tx.us.windstream.net (40.134.242.199) 36.764 ms 36.794 ms 36.792 ms
    11 * * *
    12 * * *
    13 * * *
    14 * * *
    15 * * *

    19/06/2018 23:17:18 UTC
    --------------------

    MTR:
    Start: Tue Jun 19 23:17:18 2018
    HOST: Blizzard Loss% Snt Last Avg Best Wrst StDev
    1.|-- 24.105.30.2 0.0% 10 0.6 2.4 0.4 12.2 3.9
    2.|-- ??? 100.0 10 0.0 0.0 0.0 0.0 0.0
    3.|-- 137.221.66.6 0.0% 10 1.4 1.5 1.4 1.6 0.0
    4.|-- 137.221.68.72 0.0% 10 1.1 1.2 1.1 1.2 0.0
    5.|-- 137.221.68.34 0.0% 10 1.2 1.0 1.0 1.2 0.0
    6.|-- 213.248.78.166 0.0% 10 1.4 1.4 1.2 2.7 0.3
    7.|-- dls-b21-link.telia.net 0.0% 10 31.3 32.2 31.2 40.1 2.7
    8.|-- 213.248.82.238 0.0% 10 31.3 33.6 31.3 53.3 6.9
    9.|-- xe0-2-3-0.cr02.dnvt01-co.us.windstream.net 0.0% 10 31.4 31.9 31.3 36.6 1.5
    10.|-- xe11-2-0-0.pe06.txrk01-tx.us.windstream.net 0.0% 10 36.8 36.8 36.8 36.9 0.0
    11.|-- ??? 100.0 10 0.0 0.0 0.0 0.0 0.0

    19/06/2018 23:17:18 UTC
    --------------------

    </code>
  • Howdy!

    Diablo III requires a constant and stable connection. The connection goes from your PC to the router -> Modem -> ISP -> Multiple other ISPs before getting to us and issues can occur along that route. Your route depends on where the servers are. We do not have any outstanding connection issues at the moment for North America.

    I would recommend to try the following steps to refresh the connection:

    1) Power cycle the connection to refresh the connection.

    2) Once the PC is back online flush your DNS cache.

    3) If you are using Wifi try switching to a wired connection.

    Retest. If the issue continues try what Maskraider recommended which was to capture the problem with a WinMTR running and post the results back here for review! Make sure once you pasted the results to your rely to highlight the text, and select the code block </> icon to make it easier to review.

    Thank you.