Resolution Scaling Problem

  • This has been a problem for a while. Since the first big patch you guys put out, the way the game scales has been impossible to play.

    I want you to read this, because this is not just a Diablo issue but a Blizzard issue

    http://us.battle.net/sc2/en/forum/topic/6606363101

    These are the problems that I am having with both games. The only difference is before this patch, I was able to bring down my desktop resolution so it could scale down. Now I wont scale at all and it is impossible to micro. I cannot be forced to move my mouse from corner to corner of my mousepad to micro my character. Here is some advice, SC2 WOL works perfectly, whatever has been done with the resolution there is how it should be. WHEN YOU GO TO A LOWER RESOLUTION THERE IS LESS MOUSE MOVEMENT REQUIRED AND THE CURSOR GETS BIGGER. Now in HOTS and D3 this is not the case anymore and it is literally impossible to play. It is so bad that I will not buy another Blizzard game until this issue is fixed. All my info is in the thread above and something needs to be done because 27" iMac users are suffering because of this. When you cannot use the pivot of your wrist to micro and have to use your whole arm, you cannot be competitive and will be more frustrated than anything. Please figure out the fix for this, there is something being done to these two games that similar.
  • I think I understand this a bit more. This may be relating to the display mode change.

    Read more about this here: http://us.battle.net/wow/en/forum/topic/6471447232#4

    This is not implemented in WoL yet, and It was semi active in D3, but it was capped at the desktop resolution and not the native resolution.

    This is because changing the in-game resolution does not change the whole OS resolution like before.

    Are you able to try the workaround to disable the change? Try to type this in the Terminal:

    <code>defaults write com.blizzard.diablo3 DesktopModeIsDefault 1</code>
  • Yes.
  • Sorry I corrected the terminal input. Try this:

    <code>defaults write com.blizzard.diablo3 DesktopModeIsDefault 1</code>
  • This is an intended change. I'll provide that feedback up to the team for review though and see what they say.
  • 10/17/2012 02:31 PMPosted by SiCkXecutor
    defaults write com.blizzard.StarCraft II Beta DesktopModeIsDefault 1

    You won't be able to do it with spaces like that. Let me experiment a bit.
  • com.blizzard.starcraft2.plist

    Try:
    <code>defaults write com.blizzard.starcraft2 DesktopModeIsDefault 1</code>
    The thing is, the beta shares the same preference files as the live game.