No Sound

  • I recently re-downloaded D3 on my new computer and I have no sound at all. It's not like this on other Blizz games, (such as WoW). I've tried the old blue trick of changing the sound quality to CD, I've checked all drivers and they're all up to date, I've tried disabling all extra sound options/enhancements, I've checked that no obvious sound settings in game or on my computer are turned off, I'm not really sure what the issue is. Everything else on the game works fine, it's just totally silent.

    Audio Codec: Realtek ALC3266
    Driver version is: 6.0.1.8098

    I'm not sure which sound card it has, it's an AW15R3-7376SLV-PUS
    basic Realtek audio
  • Does this occur with different headphones\speakers? If its a desktop and if you're using headphones\speakers with a 3.5 mm jack, have we tried testing with both the front and back panel ports on the computer? What are you currently using to output audio (include the model if possible)?
  • Elagarf,

    Start up the game and then alt-tab out to right click on the speaker icon on the lower right side of your task bar. Select Open Volume Mixer and check the settings for the game. Make sure it's not muted and that the volume level hasn't been set all the way down. If you happen to be using a Razer headset, be aware that the Razer Synapse Mixer app they use can also individually mute games.
  • Elagarf,

    Could you post your D3Debug.txt file from your Diablo III\x64 folder? Also, post the D3Prefs.txt file from your Documents\Diablo III folder.
  • Elagarf,

    "2018.02.28 19:18:22.397762800 Initializing sound with 128 channels
    2018.02.28 19:18:22.460404800 Falling back to FMOD_OUTPUTTYPE_DSOUND
    2018.02.28 19:18:22.537802800 FMOD Error during 'FMOD_System_Init': A call to a standard soundcard driver failed, which could possibly mean a bug in the driver or resources were missing or exhausted.
    2018.02.28 19:18:22.538015500 FMOD Memory - total: 178257920
    2018.02.28 19:18:22.538185800 FMOD Memory - allocated: 43064, - max allocated: 841928
    2018.02.28 19:18:22.538411100 Sound subsystem failed to initialize!"

    This all means no sound for you in D3

    I'd try a couple of things for this. In the game, set it to use a lot less sound channels like 16 or 32. In Windows, reinstall or update your sound drivers.

    Latest Realtek drivers can be found here:

    http://www.realtek.com.tw/downloads/downloadsCheck.aspx?Langid=1&PNid=24&PFid=24&Level=4&Conn=3&DownTypeID=3&GetDown=false

    Getting to them can be tricky:

    hover along the left
    Computer Peripheral ICs - PC Audio Codecs - High Definition Audio Codecs - Software
    Agree to the question, click Next
    64 bit version is second choice from the top