(FIXED IN PTR!) Stutter every minute or two

  • *Update: Just played PTR and no more stutter, I'm coming back!*

    TL:DR first post helped fix my 64 bit
    32 bit also fixed it but like 64 better
    still occasional stutter not as bad, awaiting the pros

    Im playing high framerates 1440p but since I come back after a while I am getting this awful stutter. Is it my norton, EVGA precision, Razer, Logitech? Need some ideas. My pc plays wow very well many hours a day and used to play d3 well, only thing I added since was a Razer Black Widow RGB keyboard. Also note I use Norton, is there somehow I can allow all D3 traffic?

    Also want to add fullscreen/windowed fullscreen, Vsync on off, gsync on off doesnt fix it. And I reset settings so sounds went back to default.

    Going to uninstall EVGA precision, restart and test, i think that is new too.

    Edit: It wasn't EVGA precision

    Now Im gonna try to turn off windows game bar

    Edit: It wasn't windows game bar

    Now trying 32 bit

    Final Edit: FPS doesn't feel as great as 64 bit but 32 bit removed my stutter. I'm gonna go play now.
  • Hi there friends,

    We have seen a few reports of this and have seen improvments by disabling the new Windows full screen optimization.

    • In the Blizzard App, select the Options drop down in the game tab and select Show in Explorer
    • Right-click on the game .exe and select Properties
    • Go to the Compatibility tab and check the box ‘Disable fullscreen optimizations’
    • Press Apply and OK

    If this works, please post back and let us know!

    /Nathardrick