Game launching attempts end in crashes

  • Hi i just got the weirdest of interactions...I just left a public rift game went afk for 5-10 mins and when i got back i saw white screen with the message:"Diablo III was unable to initialize D3D.Click ok and retry." after clicking ok a couple of times another window pops up..."Diablo III was unable to initialize D3D.Restarting the PC might help fix the issue" with a possible "retry"button and "cancel"button.As u can guess clicking "retry" just brings the window over and over again and clicking "cancel"exits the crashed window of the game leaving me in battlenet.exe.I did restart and nothing changed.Bad thing is i didn't see anything happening bcs i went afk.Any idea for a solution?
    P.S. add an attempt to reinstall the game...still doesn't fix the problem same error...
  • Hey there Legendinho,

    This sounds like it might be a problem with Windows or with your video drivers. Lets make sure that you have the latest drivers installed, and if they are the latest then you may need to try reinstalling them.

    Updating your drivers and operating system

    If you still need help please go ahead and post the contents of your DXDIAG file. Thanks!