• " Failed to run a required program (Agent). Please wait one minute and try again. If this error reoccurs, please restart your computer and try again.
    BLZBNTBTS0000005C "
    I have tried all the suggestions to repair this problem on my MAC yet nothing has worked, don't know what else to do
  • Howdy!

    This error is often caused for Mac users due to either permission issues or corrupted data. I would recommend the following steps:

    Step 1) Delete the cache files Here -> Select the Mac tab at the top of the page.

    Step 2) Repair your Application Support Folder and Shared Folder. It's also a good idea to double check the Blizzard app and Diablo III folder permissions in the Application folder directly by following the steps Here for each program.

    Step 3) Double check your Operating System's Firewall to ensure the game and Blizzard app are allowed by following the steps Here Click 0n the drop down for Max OS X for the steps.

    Retest! Let us know if the issue continues!