No DSR resolution on Acer Predator X34

  • Hi to all,

    I've just received my Acer predator X34 but I can't see any resolution selectable beyond 1920*1440. The DSR is enabled in the Nvidia control panel and nonetheless I can't select any DSR resolution.

    Any clue?
  • Pucidbu,

    Are you checking the resolution options for full screen mode in the game? I just verified DSR works properly here at work but I'm not using a 21:9 ratio screen. I have one at home but I've not tried playing Diablo III on it since I got it as I've been too tied up in Wow right now. Users have been telling other users inquiring about getting the full res to use windowed fullscreen mode. I'll see if I can fire up the game tonight and see what's going on and post again tomorrow unless you've figured it out by then.
  • Pucidbu,

    Ok, so here's what happened. When using my 3440 x 1440 display, I could not get Diablo III to offer any of the DSR resolutions in the game. I was offered them in the Nvidia Control Panel for changing the desktop resolution however so the feature is working as it should. I'm pretty sure it's just the fact that the game doesn't directly support the 21:9 ratio.

    I tried on another PC i have using a 2560 x 1600 (16:10) and it worked as expected with the DSR modes.

    But, when using the larger screen, the game looked absolutely great to me especially with Gsync keeping it at 100Hz. I set it to use 2560 x 1440 Full screen, then switched it over to Full screen windowed and there was no discernible stretching. It displays across the entire monitor and like I said looks and runs great. Full screen windowed should be using the desktop resolution which for me is 3440 x 1440. I'll need to figure out a way to see what it really is.
  • Pucidbu,

    I'm using an Asus ROG PG348 which is essentially equivalent to your Acer
  • Pucidbu,

    Hmm, I didn't do anything special really. Just have the desktop resolution set to the screen's native 3440 x 1440. Using the 64 bit client in the game in case you're maybe using the 32 bit one.
  • Pucidbu,

    It's selectable under the Game Settings in the Blizzard Desktop App for Diablo III.

    By the way, here's a screenshot of the video choices I see
  • Pucidbu,

    Did you verify your desktop resolution is set correctly as my second screenshot link shows? 1920 x 1440 is a valid selection too but you don't want it set there.

    PreferencesVersion "46"
    PlayedCutscene0 "0"
    PlayedCutscene1 "0"
    PlayedCutscene2 "0"
    PlayedCutscene3 "0"
    PlayedCutscene4 "1"
    DisplayModeFlags "0"
    DisplayModeWindowMode "2"
    DisplayModeWinLeft "495"
    DisplayModeWinTop "59"
    DisplayModeWinWidth "1889"
    DisplayModeWinHeight "1092"
    DisplayModeUIOptWidth "2560"
    DisplayModeUIOptHeight "1440"
    DisplayModeWidth "3440"
    DisplayModeHeight "1440"
    DisplayModeRefreshRate "100"
    DisplayModeBitDepth "32"
    DisplayModeMSAALevel "1"
    Gamma "1.000000"
    MipOffset "0"
    ShadowQuality "5"
    ShadowDetail "0"
    PhysicsQuality "1"
    ClutterQuality "3"
    Vsync "0"
    LargeCursor "0"
    Letterbox "0"
    Antialiasing "1"
    DisableScreenShake "0"
    DisableChromaEffects "0"
    LowFX "0"
    SSAO "0"
    LockCursorInFullscreenWindowed "0"
    LimitForegroundFPS "0"
    MaxForegroundFPS "150"
    LimitBackgroundFPS "0"
    MaxBackgroundFPS "8"
    DisableTrilinearFiltering "0"
    ColorCorrection "1"
    MipBias "-0.000000"
    ReflectionQuality "0"
    HardwareClass "4"
    PCIVendor "4318"
    PCIDevice "6918"
    flSafeZoneLeft "0.000000"
    MasterVolume "1.000000"
    EffectVolume "0.800000"
    MusicVolume "0.800000"
    NarrationVolume "0.800000"
    AmbientVolume "0.800000"
    ChannelsToUse "32"
    SoundDriver "0"
    SpeakerMode "0"
    ReverseSpeakers "0"
    QuestSubtitlesEnabled "0"
    CinematicsSubtitlesEnabled "0"
    PlayInBackground "0"
    MuteSound "0"
    MuteEffects "0"
    MuteAmbient "0"
    MuteVoice "0"
    MuteMusic "0"
  • Afterburner is running but just for overclocking the GPU, but that's recent addition. D3 was the same for me before Afterburner.