My achievements Are gone!

  • I just updated to 2.1.0 and all my achievements are gone and where it should say "Achievements" I says "!!Missing!! - 0"
  • Hi Everyone,

    I just wanted to chime in and let all of you know that we are aware that we are actively investigating this issue, and hope to have a resolution in place soon.

    In the short term, the log out workaround (detailed here) is working for many players and we encourage you to give that a try if you are experiencing this. Please note that this is just a temporary workaround, and may not work for all players. If this does not work for you right away, please wait a short while and try again.

    We really appreciate your patience while we are working on a permanent resolution. Thank you all for the reports about this!
  • 08/26/2014 05:49 PMPosted by Draco
    Hey Tsarnis. Thanks for getting back to us. Now the thing is, I am patient and don't mind waiting for the fix, however I need to know if any achievements our characters get between now and when the fix is deployed will be accounted for or not. Because if the achievements we unlock now aren't good, then I will want to hold off on playing until the fix is rolled out but if you're going to let the achievements be retroactive once the fix is out, then I will gladly start playing. Please let me know, thanks.

    This is a very good question. This issue is a display issue only, and achievement data is actually being loaded and tracked while in-game. Any achievement progress you make until we resolve this issue should be retained without issue.
  • 08/27/2014 12:26 AMPosted by DrOfDeath
    I tried Kelo's method of changing regions and then changing back and it worked.

    Several players have reported that this has worked for them. For those of you who are still experiencing issues with the Achievements UI, this might be worth a shot.

    Thanks to everyone for their patience. We are continuing to work on this!
  • Hello everyone! Just wanted to jump in to clarify a few things.

    If you are still affected by the Achievements UI bug, please try switching to the Europe servers from the login screen, hit Play to launch the game, log out, then try switching back to the Americas servers. This should solve the issue. If it doesn’t, please let us know in this thread.

    In the meantime, we believe we have identified the problem and are working with our ISP to resolve it as soon as possible. Once again, your achievements and progress are not lost.
  • 08/29/2014 02:05 PMPosted by EnkerZan
    Hello, I tried the method to fix this problem and it still persists. Can you please help? I am missing out on a lot of achievements.

    08/29/2014 02:09 PMPosted by RayIxI
    I have done everything mentioned and am still not able to see my achievements please help. Thank you.

    Understood! Sorry you're still having this issue, folks, and thanks for letting us know it persists. We're continuing to investigate and troubleshoot more permanent solutions and will work to keep you all as updated as possible in this thread.
  • We've successfully developed and deployed a fix for this issue in all regions. At this time, this particular achievement display bug should be resolved. Thanks for all your feedback, everyone!