Ability phantom key presses

  • I've been struggling with this issue for a while now (even before the latest patch). I have tried to troubleshoot it on my own but have been unable to find a solution.

    When playing on multiple characters I have noticed phantom key presses. So far it has only been on my ability keybinds (1,2,3,4 and numpad 1, 2, 3, and 4). I have a Logitech G600 mouse with the extra buttons keybound to the numpad and am using a mechanical keyboard. It usually happens the most on my first ability, but also happens on my third and fourth. Currently it hasn't happened on my second ability.

    It happens completely at random, and when it does it usually lasts for at least a couple of minutes. Then it will stop, and I can have no issues at all, then it comes back later. It's almost as if someone is holding that key down on my keyboard and/or mouse for those few minutes. For example, on my demon hunter my first ability is my sentries. At random, all three sentries will be placed, and the game will continue to try to place more sentries even while on cooldown (my character will keep telling me I can't use that ability yet). As soon as it comes off cooldown, another sentry is placed. This happens with my hands completely off the mouse and keyboard.

    Note that this does not happen in any other programs or games besides Diablo 3. I am also an avid World of Warcraft player and this has never happened while playing. When it starts happening, I have switched programs to Notepad or Chrome and nothing happens. When I go back to Diablo it stops.

    Here is what I have tried so far with no luck:
      I purchased a new mouse and new keyboardUninstalled and reinstalled the gameReset my game settingsScanned the game for repairs (no repairs found)Tried different USB ports on my desktopTried a different characterChecked my keybind settings to make sure they were correctDid a virus scan on my machine

    I also built myself a new computer a couple months ago and that didn't help. Everything is new except for the case and SSD my games are on.

    Any help is greatly appreciated!
  • Hey there!

    Read over this and if you have a Nvidia graphics card then I would like to look into disabling Nvidia Share. Usually the opposite issue occurs where key presses are not recognized. But as this can affect key presses I would like to try disabling the feature just in case!

  • Would we be able to uninstall the Logitech Gaming Software and test using just the keyboard rather than the mouse buttons?