Launcher problems updater agent.exe solved

  • I figured I better post this before Blizzard takes credit for figuring it out. The Blizzard updater is out of control it is consistantly trying to update on launch even when there is nothing to update. I noticed this happening only when I wasn't cramping my bandwidth with other downloads which I usualy do. Launcher would start and say updating launcher or have a status bar and nothing downloading and PLAY button unusable. Well here it is the agent.exe process is indeed the culprit and ties directly into the updater so this problem was easy to fix after I nailed down the cause. Go into firewall setings and deny the Blizzard updater access bam problem solved no issue at all now. This wouldn't have been possible though withought the great support team telling me to try the same things over and over and having me send useless information to them saying it would help. Oh and I can't forget telling me to try uninstalling my ethernet driver and trying the game. Yeah for real that's not even a joke. A Blizzard employee asked me to try not using the internet to play an internet based game as a troubleshooting method.
  • mrgrynch,

    I'm glad you were able to work out your issue with the launcher but I need to ask you to stop bumping old posts as you've been doing.