No sound on 2.4.3

  • After upgrading to patch 2.4.3, D3 no longer generates sound in the application. I use the generic windows 10 sound driver which worked on previous patches as well as other applications including Overwatch.

    I'm not using a manufacturer driver (Realtek) because that has other issues, and even in attempting to use their driver, although D3 generated sound, it was distorted. I'd like a solution that allows me to use the generic windows driver - at least until Realtek fixes their own issues.
  • YellowInk,

    Start up the game and then alt-tab out to right click on the speaker icon on the lower right side of your task bar. Select Open Volume Mixer and check the settings for the game. Make sure it's not muted and that the volume level hasn't been set all the way down. If you happen to be using a Razer headset, be aware that the Razer Synapse Mixer app they use can also individually mute games.

    If that's not the issue, please post your D3Debug.txt file from your main Diablo III game folder.
  • YellowInk,

    Do you see D3 among the apps listed in the mixer? If not, it sounds like the game isn't finding a compatible sound device to use. The D3Debug file will tell us if that's the case.

    To post the file, open it with a text editor like Notepad, Select all the text with Control-A, copy it to your clipboard with Control-V, and paste it into your response with Control-V.
  • YellowInk,

    This file doesn't appear to be current as noted by the timestamp - 2016.12.29

    Go ahead and delete it and then launch the game again, exit it and then post the new D3Debug.txt file that's created.
  • YellowInk,

    Starting the game and exiting it should be enough, It just keeps a record of the tasks being done when you launch up until you exit.

    However, I just tried here at work and it's not generating a file for me as well.

    Ah, turns out it's now in the Diablo III\x64 folder.
  • YellowInk,,

    Ok, so here's where the problem lies.

    2017.01.05 19:50:11.646000200 Selecting driver 0 (Headphones (High Definition Audio Device))
    2017.01.05 19:50:11.649335500 Speaker Mode: 7.1
    2017.01.05 19:50:11.653919500 Initializing sound with 32 channels
    2017.01.05 19:50:11.685897200 Falling back to FMOD_OUTPUTTYPE_DSOUND
    2017.01.05 19:50:11.864745800 FMOD Error during 'FMOD_System_Init': A call to a standard soundcard driver failed, which could possibly mean a bug in the driver or resources were missing or exhausted.

    Your other debug file from last week indicated it was using a different driver it had found:

    2016.12.29 11:33:16.397888000 Selecting driver 0 (Headphones (A Stereo))
    2016.12.29 11:33:16.398193400 Speaker Mode: Stereo
    2016.12.29 11:33:16.398594700 Initializing sound with 32 channels

    Can you try selecting from the different sound devices in the game and see if there's one matching what you had earlier? I'm not familiar with "A Stereo" but it's not showing up in 2.4.3 apparently or it's not currently on your PC any more.
  • YellowInk,

    Could you try selecting the regular stereo speaker mode in the game instead of 7.1 and see if it has any effect?