Won't install due to no default language

  • Hello,

    I cannot get the Battle.Net to update/install Diablo 3. I already have it installed, but I haven't played it in about a year. I went to try and update/install it and it go to to the screen to confirm and select default language (which nothing is selectable/shown). When I try to continue the next screen gives me the error that I have to select a default language. However, like I said - it isn't showing me the option in the previous screen.

    I've read the forums and tried switching the language and restarting, no luck.

    I'm on a Mac, running 10.12.2 and the Battle.Net is No file vault turned on.

    Please help as I can't play/install the game.
  • Hey Kolden,

    Please do try the steps here to help get the language options to show up and get
    Diablo III installed.
      1) Go to settings (Battle net icon in your top left corner)
      2) Change your language (Any will do)
      3) Try installing again and you will be presented with more install options
      4) Once the install starts, "Game Options" should become available and you can change your languages back to English (or whichever is desired)

    If the above steps do not work, delete these Battle.net files here and here.