Error BLZAPPBTS0000J Trying to Install D3

  • using my macbook pro with a fresh installed logged in under root, to minimize security, i start to run the main application from my D3 install disc, and it says "searching for battlenet updates", the progress bar goes a little into the blue, then it flashes the word "downloading" and immediately goes to an error window that says "Something went wrong while trying to launch a program. please wait one minute and try again. if it happens again, try restarting your computer" with the error code listed in the subject "BLZAPPBTS0000J" as the reason. I have tried getting rid of every process i could, took all security off and logged in as root (sys admin) with no security and absolutely the most privilege that the OS will allow … i even did all of this AND entered safe boot mode (i tried installing both ways, safe boot and standard, under multiple user names, all with admin, AND as root) and i still cannot get away from this error. no file vault is active, fresh install of OS X, 745GB free space, wide open hardline LAN, 8GB RAM, plenty of system, and still a fail!! I've had my copy of D3 installed on this same Mac before, and had no issue what so ever installing or running it, but now, i can't even install battlenet!! why this error? what fixes it? I've tried all of the suggested stuff and nothing works … please help!!!
  • Hey Caboose!

    Sounds like you have gone through a bit of troubleshooting which is good to narrow down the root of the issue. Looking over the post, it may not be a bad idea to try and deleting the files.

    It may not be a bad idea to make a brand new administrator account for your system as well and see if that helps.
  • Hello all,

    Let's make sure to remove everything for the App they may have been installed and then install a fresh version from it from the website. The information on the disk may be old and not updating properly.

    1) Use Activity Monitor to quit all Agent,, and game processes.
    2) Using Finder, click the Go menu and select Computer.
    3) Navigate to the /Users/Shared
    4) Delete the and Blizzard folder.
    5) Navigate to the /Applications folder and delete the folder.
    6) Empty the trash on the Mac
    7) Install the App from here. Once the App is installed install Diablo III via the app.