Graphics error-click to retry d3d device

  • Hey! Yesterday I was playing without any problems. However, today I just patched up 2.1 and so then when I click 'play now' in the battle.net applicaton it seems like the game will run but then black screen and it says' Graphics error-click to retry creating D3D device. I clicked 'ok' like 500 times, updated my driver, uninstalled-reinstalled the game but nothing changed. Could someone help me how to fix this bug? It's absolutely annoying, I've wasted like 3 hours today trying to fix this..:(
  • Rolifumi,

    Can you post some information about your computer? You can find this information in the Direct X Diagnostic Tool:

    Click on Start
    Click on Run
    Type in: dxdiag (In Vista, type dxdiag in the search field)
    Hit Enter or OK

    Click on the Save All Information button at the bottom, and create a dxdiag text file, and copy and paste it ALL here.

    Could you also post your D3Prefs.txt file? It's located in the My Documents\Diablo III folder.

    _________________________________________________________
    I'm available in the forums Tuesday - Friday, 11 am - 8 pm Pacific Time
    Saturday 10 am - 7 pm Pacific Time
    Feedback? - https://www.surveymonkey.com/s/Omrakos
  • Rolifumi,

    Your refresh rate appears to be incorrect.

    There are a few conflicting values showing up in your dxdiag.

    Current Mode: 1920 x 1080 (32 bit) (30Hz)
    Monitor Name: SyncMaster P2350(G)/P23500(G),Magic P2350G(Digital)
    Monitor Model: SyncMaster
    Monitor Id: SAM0526
    Native Mode: 1920 x 1080(p) (60.000Hz)

    Monitor Name: Általános PnP képernyő
    Monitor Model: 26LC2R-ZJ
    Monitor Id: GSM561E
    Native Mode: 720 x 480(p) (59.940Hz)

    and then in your D3prefs file:

    DisplayModeRefreshRate "50"

    Set your desktop resolution and refresh to match your monitor's native spec which is 1920 x 1080 @60Hz

    Set the game to the same, do not use a 50Hz refresh rate as you are now. Edit the file if necessary to match.

    _________________________________________________________
    I'm available in the forums Tuesday - Friday, 11 am - 8 pm Pacific Time
    Saturday 10 am - 7 pm Pacific Time
    Feedback? - https://www.surveymonkey.com/s/Omrakos
  • RquesT,

    You might try enabling Vertical Sync to see if it helps first.

    To do that, just change this line in your D3Prefs.txt file.

    Vsync "0"

    change to

    Vsync "1"

    If that doesn't help, please post your D3Debug.txt file. It's located in your main Diablo III game folder.

    ______________________________________________________________
    I'm available in the forums Monday - Friday 6:30 am - 3:30 pm Pacific Time,
    Feedback? - https://www.surveymonkey.com/s/Omrakos
  • Geralt,

    Could you please post some information about your computer? You can find this information in the Direct X Diagnostic Tool:

    Click on Start
    Click on Run
    Type in: dxdiag (In Vista, type dxdiag in the search field)
    Hit Enter or OK

    Click on the Save All Information button at the bottom, and create a dxdiag text file, and copy and paste it ALL here.

    ______________________________________________________________
    I'm available in the forums Monday - Friday 6:30 am - 3:30 pm Pacific Time,
    Feedback? - https://www.surveymonkey.com/s/Omrakos
  • Nora,

    Have you rebooted the PC since this occurred and if so, is it still happening? If it is, could you please post some information about your computer? You can find this information in the Direct X Diagnostic Tool:

    Click on Start
    Click on Run
    Type in: dxdiag (In Vista, type dxdiag in the search field)
    Hit Enter or OK

    Click on the Save All Information button at the bottom, and create a dxdiag text file, and copy and paste it ALL here.

    ______________________________________________________________
    I'm available in the forums Monday - Friday 6:00 am - 3:00 pm Pacific Time,
    Feedback? - https://www.surveymonkey.com/s/Omrakos
  • Nora,

    Try making the following changes and see if it helps.

    Edit your D3Prefs.txt file, located in the My Documents\Diablo III folder.

    We'll want to set the game to use the monitor's native resolution, refresh rate, windowed mode, and enable vertical sync primarily.

    To do that, look for the lines beginning with:

    DisplayModeWindowMode
    DisplayModeWidth
    DisplayModeHeight
    DisplayModeRefreshRate
    Vsync

    and change them to:

    DisplayModeWindowMode "1"
    DisplayModeWidth "1800"
    DisplayModeHeight "900"
    DisplayModeRefreshRate "60"
    Vsync "1"

    ______________________________________________________________
    I'm available in the forums Monday - Friday 6:00 am - 3:00 pm Pacific Time,
    Feedback? - https://www.surveymonkey.com/s/Omrakos