Diablo 3 was unable to initialize a streaming

  • Yes, I am having the problem on start up where it is unable ot initialize a streaming connection. I went throuhg, made sure both the battle.net troubleshooter, including making sure all the correct ports were opened and that the secondary login was enabled, and the diablo 3 trouble shooter, including that all the ports were enabled, and everything was done on that list. Not sure what else to do, would like to play the game and i can see the servers are not down due to my friend being able to get on while mine is still crashing before it starts.
  • Suikoboj,

    1. Are you seeing this message from the Battle.net launcher or a Diablo III screen?

    2. If you are using a wireless connection, try using a wired connection to see if that helps.

    3. What security programs do you have installed? Try temporarily disabling them to see if that helps.
    ______________________________________________________
    I'm available Sunday through Thursday from 11AM to 8PM Pacific Time
    Support Contact Information

    Got some feedback?
  • Suikoboj,

    Let's try deleting the Battle.net Tools folder to see if that helps.

    Here's how to do that:

    1. Restart the computer.
    2. Ensure that show hidden files and folders is enabled.

    3. For Windows Vista and 7: Click Start and select Computer.

    -Windows XP: Click Start and select My Computer.
    -Windows 8: Windows Key + Q and select Computer.

    4. For Windows Vista and 7: Double-click the C drive, then the ProgramData folder, and then delete the Battle.net folder.

    -Windows XP: Double-click the C drive, then Documents and Settings, then All Users, then Application Data, and then delete the Battle.net folder.
    -Windows 8: Double-click the C drive, then the ProgramData folder, and then delete the Battle.net folder.

    Note: The above steps may cause Battle.net to forget game install locations. If your games can’t be found, you will see Install on the Battle.net game tab instead of Play. To find your installation, click Locate this game or run the game launcher.
    ______________________________________________________
    I'm available Sunday through Thursday from 11AM to 8PM Pacific Time
    Support Contact Information

    Got some feedback?
  • Suikoboj,

    1. Make sure that your LAN settings and Internet Explorer settings are set correctly.

    Here's a support article that will help:

    Disabling Proxy Settings

    2. Make sure that your Windows Secondary Logon service is enabled.

    Here's a support article that will help with that:

    Enabling Windows Secondary Logon Service

    3. Make sure that you are running the launcher as an admin by right clicking on the launcher icon and selecting "Run as admin".
    ______________________________________________________
    I'm available Sunday through Thursday from 11AM to 8PM Pacific Time
    Support Contact Information

    Got some feedback?