All users will need to merge their Diablofans account with a new or existing Twitch account starting Nov 20th. You can merge your accounts by clicking here. Have questions? Learn more here.
Dismiss
  • 0

    posted a message on Diablo III Beta System Requirements
    Quote from PakstraX

    Quote from OnTheLosse

    My graphics card is: ATI Radeon HD 4200

    I kept trying all the resolution, and in full windowed mode, and in just windowed mode. They were all the same for lag.

    I'm sorry to inform you, but HD4200 is worse than x1950 Pro, I would recommend buying a better card if you plan on playing the Beta or the game after... maybe something like HD6670 (it shouldn't be expensive - $70 or $80)...
    How can my graphics be that bad, the computer is only a couple months old and it wasn't cheap. Maybe there will be a low graphics option at release as there is only medium quality as it stands. Well thanks anyways, I guess if nothing changes ill just tread through the slight fps lag or whatever.
    Posted in: Technical Support
  • 0

    posted a message on Diablo III Beta System Requirements
    My graphics card is: ATI Radeon HD 4200

    I kept trying all the resolution, and in full windowed mode, and in just windowed mode. They were all the same for lag.
    Posted in: Technical Support
  • 0

    posted a message on Diablo III Beta System Requirements
    Thanks, cause on the beta login in screen(I just have the client downloaded, not actually in it) the options are really laggy when going from one such as video to sound, it takes a while for it to be highlighted, and my graphics card is better than minimum too for sure.
    Posted in: Technical Support
  • 0

    posted a message on Diablo III Beta System Requirements
    Could someone tell me if my processor is better than the minimum, I'm assuming it is.

    Mine: AMD Athlon(tm) II X4 645 Processor (4 CPUs), ~3.1GHz
    Minimum: AMD AthlonTM 64 X2 4400+
    Posted in: Technical Support
  • 0

    posted a message on Diablo III Beta System Requirements
    I downloaded the leaked beta client like other people, and just changing some options around, I found that it was really laggy from going to one option and it highlighting it to the next. My graphics card is an ATI Radeon HD 4200 which is better than the minimum. My computer is only like two months old so I don't know what's up with it. I even tried lowering the resolution and putting it into windowed mode, and it only made it slightly better.

    I'm not really worrying about it for now since I'm not(and probably won't be) in the beta. Just wondering if anyone had a clue why it was so laggy with a better than minimum graphics card. Oh, and all the sounds happen when I click and don't lag if that makes any difference.
    Posted in: Technical Support
  • To post a comment, please or register a new account.