All users will need to merge their Diablofans account with a new or existing Twitch account starting Nov 20th. You can merge your accounts by clicking here. Have questions? Learn more here.
Dismiss
  • 2

    posted a message on Diablo 3 cannot run because this card is missing required features
    Quote from JohnBongo

    Quote from kittty66

    Damn, doesn't work with HD2600 PRO 512MB, whyyy? Crysis2(medium settings), Starcraft2(high settings)...All working just fine..So why the hell diablo doesn't even start? :(((

    Same card, same problem :( updated all drivers etc. and nothing.... It couldn't be that D3 wouldn't work on it... :(

    PS. according to graphic card list posted earlier: "0x1002|0x9581|Low|ATI Mobility Radeon HD 2600" so it should be supported....

    heh, found a solution!

    Inside folder libraries/documents/diablo III there is a file "D3Prefs"

    Changed:
    - DisableTrilinearFiltering "1" (from 0 to 1)
    - HardwareClass "1" (from 0 to 1 as well)

    And it's working :D

    Now i can stare at login screen while waiting :D

    But still, this temporary solution might be helpful for someone.
    Posted in: Technical Support
  • 0

    posted a message on Diablo III Beta System Requirements
    Quick question:
    i have a graphic card exactly as posted as minimum: radeon HD 2600 pro (i know it's crappy, but still works, and with overdrive it works even fine) and it still shows me "Diablo 3 cannot run because this card is missing required features" (just a leaked client, but updated) all drivers up to date and what now?
    Posted in: Technical Support
  • 0

    posted a message on Diablo 3 cannot run because this card is missing required features
    Quote from kittty66

    Damn, doesn't work with HD2600 PRO 512MB, whyyy? Crysis2(medium settings), Starcraft2(high settings)...All working just fine..So why the hell diablo doesn't even start? :(((

    Same card, same problem :( updated all drivers etc. and nothing.... It couldn't be that D3 wouldn't work on it... :(

    PS. according to graphic card list posted earlier: "0x1002|0x9581|Low|ATI Mobility Radeon HD 2600" so it should be supported....
    Posted in: Technical Support
  • To post a comment, please or register a new account.