All users will need to merge their Diablofans account with a new or existing Twitch account starting Nov 20th. You can merge your accounts by clicking here. Have questions? Learn more here.
Dismiss
  • 0

    posted a message on Hellfire 1.01 patching windows 7
    Back when I first installed Diablo on Windows 7 I was unable to patch Diablo because I run 64 bit Windows, I had to install Diablo on another computer, patch it and copy the patched version ontop of my Windows 7 Diablo. For the Hellfire patch I just used some program to extract the files directly from the patch and put them in the Hellfire directory. The executable extractor didn't work with the regular Diablo patch because Blizzard use their own patcher which was unsupported by the extractor.
    Posted in: Diablo I & Hellfire
  • 1

    posted a message on Windows 7 and Diablo 1 (merged threads)
    When it comes to playing on lan my friend and I was able to play simply by using Hamachi. One creates a network in Hamachi and the other connects to said network, it lets you play on IPX.
    Posted in: Diablo I & Hellfire
  • 0

    posted a message on More Diablo Animations?
    Quote from "Mordor" »
    Black is right for shadow.
    However, part of this demon's legs is colored black, which, as far as I remember, wasn't the case originally - they were (very) dark red. Which also looks not like red, but pretty dark, without creating a feeling that it's too dark.
    Hmm, I guess I'll just have to try some of the colors in the palette file and find one that fits, I'm just such a perfectionist that I can't rest unless I know I have the right colors. :P
    Quote from "Sixen" »
    I have to ask, which MPQ Editor are you guys using? I've got WinMPQ.
    I'm using cv5, it lets you view and save cel and cl2 files as gifs.
    Posted in: Diablo I & Hellfire
  • 1

    posted a message on More Diablo Animations?
    Quote from "Mordor" »
    unique TRNs are not really that unique
    all TRNs just have to be picked very carefully

    regarding that white colors: they used to be pure black originally (RGB data 000000h in .PAL file), but got converted to white in the process of extraction/conversion
    Ah ofcourse, I see white and black has been switched in the palette file. I'm not sure if pure black is the right color though, looks a little too dark.
    Posted in: Diablo I & Hellfire
  • 0

    posted a message on More Diablo Animations?
    Quote from "Clew" »
    I think you?re not using the correct pallete, if i?m not wrong Diablo 1 models had
    a different file to handle the colours
    The mpq editor I'm using came with a diablo.pal file and the Diablo 2 option under palette is unticked by default so I'm assuming it's the correct palette. I'm gonna try with some other mpq editors, if there are any.
    Posted in: Diablo I & Hellfire
  • 0

    posted a message on More Diablo Animations?
    I've been exporting some monster gifs myself, but a few of them have some missing colors, as you can see there's missing some on the side of the chest and legs on this one and it's really bugging me.



    I don't suppose anyone knows of a solution? Google isn't finding any relevant answers.
    Posted in: Diablo I & Hellfire
  • 0

    posted a message on Windows 7 and Diablo 1 (merged threads)
    Quote from "Genesis" »
    I think I have a solution for color problems involving older games and Windows 7

    I know this worked for AoE II anyway, despite all the admin rights, compatibility modes, 256 colors and disabling visual themes

    Just try closing explorer.exe when/before you open it

    IF this works then create a simple batch file that does it automatically for you, and place this .bat file in the main Diablo/Starcraft directory... such as



    This batch file should force close of explorer before starting the game. When you exit the game it reinitializes explorer.exe automatically. At least it does when I run it with AoE II

    I think its due to the Aero themes within explorer.exe for Windows 7... and something about "Microsoft Color Management Module". But dont quote me on that
    Bless you! This is the first fix that actually works for me, I had to remove the last line though because explorer opened a second after Diablo starts causing the game to minimize and the weird colors to return, but it's no big deal. Thanks man.:thumbsup:
    Posted in: Diablo I & Hellfire
  • 0

    posted a message on Φ Diablo I Moments
    A moment I remember was when I played together with my cousin, we ran into the skeleton king and got separated while fleeing from him and I was heading for a dead end. I hid in some library and closed the door after me and went over to guide my cousin to my location so he could save me, when I returned to my own computer I was dead, sorrounded by Leoric and his minions, that's when I learned some monsters can open doors. :(
    Posted in: Diablo I & Hellfire
  • 0

    posted a message on Windows 7 and Diablo 1 (merged threads)
    Quote from "Darfler" »
    I've tried every combination of compatibility and 256 colors, deleted registry entries and reinstalled D1 4 or 5 times, opened ports and when that didn't work, turned off firewall, tried downloading XP mode, that didn't work as well. I've done everything I can think of and tried all of your suggestions guys lol. Looks like I'm not supposed to play D1 over battle.net anymore. Friends and I will have to settle with skipping it and move to D2 :O)
    Thanks again for your help and suggestions, much appreciated,
    Darf
    If battle.net isn't working you could try hosting a lan game over Hamachi, just make sure you both have the same version (if you're unable to patch your game your friend might need to reinstall Diablo if he has patched his).
    Posted in: Diablo I & Hellfire
  • 0

    posted a message on The Magic and the Arcane
    Quote from "Umpa65" »
    Arcane magic basically means non elemental. It's more of a pure magic.
    This is also my impression, Diablo 1 has fire and lightning resistance, but also magic resistance and some arcane spells which aren't elemental.
    Posted in: Lore & Storyline
  • 0

    posted a message on Windows 7 and Diablo 1 (merged threads)
    I'm having the weird colors problem in Windows 7 right now, it's really strange because when I first installed it it worked just fine straight away. I haven't found a fix that works for me yet, but it worked fine without the Windows XP mode you can download for W7.
    Posted in: Diablo I & Hellfire
  • 0

    posted a message on Windows 7 and Diablo 1 (merged threads)
    I'm running Windows 7 (RC build 7100 64 bit) and both Diablo 1 and Photoshop CS4 works just fine for me, only problems I'm having is that I'm unable to update the game and Hellfire is being funky. I guess I'm just lucky.
    Posted in: Diablo I & Hellfire
  • To post a comment, please or register a new account.