Diablo-III-Setup

  • I have downloading the setup up , but it has now on it's 4th day and it still saying that it is updating blizzard agent , it's about 3/4 of the way but 4 days stright and it's still not moving yet alone done.

    Whats going on?

    My current internet speed is sitting at 25MBPS so there should be no issues or reason for it not to be done
  • Some Battle.net files could be damaged, so I'd delete the Battle.net/Blizzard folders in these temp locations:

    Press Windows Key + R and type: %LOCALAPPDATA%. Delete any Battle.net and Blizzard folders you see in this location.
    Press Windows Key + R and type: %APPDATA%. Delete any Battle.net and Blizzard folders you see in this location.
    Press Windows Key + R and type: %TEMP%. Delete any Battle.net and Blizzard folders you see in this location.
    Press Windows Key + R and type: %PROGRAMDATA%. Delete any Battle.net and Blizzard folders you see in this location.

    Then start up the Battle.net setup again, and see if that helps.
  • HULK,

    The steps Velnrak gave you are used primarily to delete the Battle.net Cache and Tools (Agent) folders that support the Battle.net Desktop App. Let's move on to reinstalling that now.

    Uninstalling the Blizzard Battle.net Desktop App - https://us.battle.net/support/en/article/30304

    You can safely skip any steps completed before.

    Also, I see your have a full account of max level characters already. How is it you are just now installing the Desktop App? Are you using a different PC now?