Latency issues

  • Bad latency issues throughout game play. It has been like this since yesterday with game stuttering and frame rate drop.
  • Hey there!

    Without more information about your system or connection, I couldn't say for sure. This may be an issue with the client or something with the system/connection. Try the following and see if that helps at all:

    Make Sure your OS and Video Drivers are up to date:

    For AMD video cards go here.
    For Intel go here.
    For all Nvidia Video cards go here.

    Flush your DNS Settings.

    Try doing a power cycle on your system. Turn off all devices including the modem. Wait 60 seconds, turn on the modem, wait 5 minutes, turn on any network devices, wait 2 minutes, turn on your computer and try the game.

    You can try switching your DNS settings to use Google's free public DNS servers instead of your ISPs Servers.

    Let's reset the in game user options:
    1. Click the blue bnet icon on the bnet app.
    2. Choose settings, then game settings.
    3. Click the reset in game user options button under the correct game listing.
    4. Confirm the changes and close the window.

    From here we need to delete the temporary game files that may be corrupted. Your game will rebuild them when you next login but this will remove all installed addons. Please do not reinstall any addons until we know the issue is resolved.

    Try running your system in selective startup mode.

    If that doesn't help, I recommend contacting us directly with some system information so we can look into this further for you.