Both monitors go black after playing

  • As said above, while playing diablo both of my monitors will turn black like they have no input. I can still hear the game in the background and my friends can still see me in-game. Doing anything else on the computer for any amount of time does not replicate this. I can play other games fine, watch movies, etc... Only happens after playing diablo, sometimes after 5min and sometimes 45min.

    PC specs:
    CPU: i7-7700k @ 4.2GHz + NZXT Kraken x62 v2
    MOBO: Asus STRIX Z270-E
    RAM: G.Skill Ripjaws V 16GB DDR4 @ 3200
    HDD: Samsung 850 EVO 250GB + Samsung 850 EVO 500GB
    GPU: EVGA GeForce 1070 SC GAMING ACX 3.0 BLACK EDITION
    PS: EVGA SuperNOVA G2 650W
    OS: Windows 10 Pro
    MONITOR: Asus VG248QE x2
  • Hey there moon,

    If your monitors are losing display from the video card that's usually an indication that the display drivers are crashing/unresponsive or there's a hardware problem going on. This sounds like it could be a TDR issue (Timeout Detection and Recovery) where the Nvidia drivers are crashing and they aren't recovering.

    Here's a few things you can try.

    1) Uninstall and reinstall your Nvidia drivers. Make sure you download the latest drivers, currently version 388.13

    2) Try rebooting in Selective Startup in order to shut down background processes and services that could be interfering with the drivers or the game.

    3) If you built the PC on your own I would double check that the GPU is full seated into the motherboard slot. Otherwise if it came pre-built I'd recommend contacting the seller/manufacturer.
  • Hey again moon,

    Thanks for the update and the additional info. If you are running the latest version of Windows 10 lets try disabling a few things to see if they make a difference.

    1. Disable the Xbox DVR

    https://us.battle.net/support/en/article/92046

    2. Try disabling Fullscreen Optimization.

    - In the Blizzard app on the Diablo 3 screen go to Options -> Show in Explorer
    - Open the Diablo 3 folder, find Diablo III.exe and right-click to select Properties
    - Select the Compatibility tab then check the box for "Disable fullscreen optimization"

    I would also try deleting your D3Prefs file from the Documents\Diablo III folder since that isn't cleared out when reinstalling the game, just to make sure everything has been set back to defaults as far as the settings.

    If those don't end up helping feel free to post your DXDIAG file and we can take a closer look.