Stuck at Fetching CDN Configuration

  • I need your help guys, so my game crashed and I've checked tons of sites to find about this problem but to no avail, I don't know what to do. I tried uninstalling D3, and reinstalling it only says on the status bar that it is Fetching CDN Configuration, so I left my PC overnight just to find out now that it is still Fetching CDN Configuration. Please Help
  • Hey PsychoArsena,

    I would start by uninstalling/reinstalling the Blizzard app. To uninstall it I would delete the Battle.net and Blizzard Entertainment folders in the hidden folder C:\Programdata as well as deleting the Battle.net folder in C:\Program Files (x86)\ Once you have removed that go ahead and reinstall the app and that should hopefully clear this up.

    If you still have issues I would temporarily disable your AV software.
  • Hey JucaWiseHawk,

    I would go ahead and try toggling proxy settings by following the below steps:
    • Press Windows Key + R.
    • Type inetcpl.cpl into the Run window.
    • Click OK.
    • Click the Connections tab.
    • Select Never dial a connection (if available).
    • Click LAN settings.
    • Uncheck Use a proxy server for your LAN.
    • If this setting is already unchecked, try to toggle Automatically detect settings.
    • Click OK.
    If that does not help I would go ahead and run a Malware scan and try switching to Google DNS.
  • @JucaWiseHawk
    Going over the traceroute, there definitely does look to be an issue with how the connection is being routed. Just looking at the second hop, we're seeing a spike of 105 ms:
    <code>2 70 ms 105 ms 28 ms 187-79-184-1.user.veloxzone.com.br </code>
    Past that we're seeing a jump from around 30 ms to 150 ms on hop 4 and timeouts occurring on hop 5:
    <code> 3 32 ms 31 ms 31 ms 100.122.49.42
    4 145 ms 144 ms 155 ms 100.122.24.12
    5 * * 37 ms 100.122.18.229</code>
    The first hop that was mentioned is going to be part of your ISP's network and so we would suggest contacting them about those early spikes.