Cannot Login:

  • When I attempt to login, it goes through the "Connecting to Blizzard Server" but never completed. It throws an error, "There was a problem connecting to Blizzard services." & There was an error (Code 2)
    I ran a trace route, and it ends at
    29 ms 31 ms 28 ms ip4.gtt.net
    * * * Request timed out.

    I can log into Heroes of the Storm fine, which is laggy constantly. May be an issue with my ISP, wanted to see if anyone else is having issues as well. Thanks!

    *Edit:
    It is a fresh install, from the client dashboard for all the games. I ran a few more trace routes and the request timed out after the same gtt.net site, but was about to complete it. I will try again in a few hours, and if that does not help I will reinstall with physical disks.
  • Hey Azurai!

    Can you run another Trace Route and post the results here in a code block*, please. Also, post your DxDiag in a separate code block.

    *To put your DxDiag in a code block, copy/paste the entire file into your next post, highlight all of it within the post box, then click the </> button.
  • Hey y'all!

    If you're not able to log into Diablo 3, try the following steps:

    If you're still having trouble after that, post your DxDiag and an updated Trace Route in separate code blocks.
  • @bobo8734

    The issue you are experiencing is completely different than the original issue this thread was created for. Please create a new thread and post your DxDiag and a Trace Route in separate code blocks.