Client Stuttering/Freezing

  • Every ~10-30 seconds the CLIENT will completely freeze for anywhere between ~3-15 seconds, eventually resume as normal and then freeze again. I believe the last time I played was season 9 - just updated the game for the Necro pack and have been attempting to 'play.'
    Have never had issues prior to this - I have several other Blizz games that run fine such as Overwatch, as well as games like Witcher 3, Black Desert, DA: Inquisition, Mass Effect: Andromeda, Skyrim (with at least 100 mods), all running on Ultra/max settings perfectly fine. There is no issue with my internet as I have ~300 down and 20 up consistently, and run through ethernet. My NVIDIA drivers are up to date. I have monitored my system while playing and the air flow is great with consistent temps. I'm not a part of any community in D3 either.

    My computer specs:
    Intel i7-6700 @ 3.7
    32 GB ram
    NVIDIA GeForce GTX 1080
    Windows 10

    So far I have:
    >ran D3 in 32bit and 64bit
    >ran in windowed, windowed fullscreen, fullscreen
    >ran in compatibility mode for Win7 and ran as admin
    >lowered my graphic settings and removed most of the dmg numbers and effects, as well as capped my FPS at 60
    >checked different areas of the game and different classes to see if this affected the issue
    >ran Windows MTR to check for packet loss/latency
    >checked Task Manager for any running background processes that would interfere and closed them
    >reinstalled Battle.net client and all Blizz games to my SSD from my HDD, repeated all of the above afterwards

    Considering that D3 ran perfectly fine up until now, I'm assuming that the issue is with some recent patch?
  • Hi there friends,

    I have a couple ideas that may help here. I know y'all just want to play with no stuttering in the game. Here is a couple of ideas for what could help here.

    First, leave any extra communities you are in. Sometimes these can cause issues exactly like you are reporting.

    Put the computer in High performance mode.

      •Press windows + X
      •Select Power Options
      •Make sure that High performance is selected
      o(If you do not see it, click the arrow to show additional plans)


    If this does not help, please get back to us with a DxDiag.

    Please post a DxDiag:
      1) Press Windows Key + R.
      2) Type DxDiag and press Enter.
      3) In the DxDiag window, click Save All Information.
      4)Name the file "dxdiag" and click Save
      5) Paste the DXdiag into the post, select and highlight everything you just pasted, and hit the "code" button (</>). That'll make the information much more readable.


    /Nathardrick
  • Hi Roney,

    In this case, I think updating your driver may help you out. Here is a link to the driver for you :) If you need more help after this, your best bet may be submitting a support ticket with your Msinfo added. Do not post your Msinfo on the forums as it is a bit much.

    /Nathardrick