Game freezes for about 5-10 secs randomly

  • Ken
    Diablo 3 keeps freezing randomly for about 5 secs in Grifts/Rifts/Bouties, it happens more regularly in Multiplayer mode. When it freezes, the whole screen is locked up, mouse and keyboards become disabled.
    System:
      core i7
      Nvidia 965m dual SLI

    I have tried every single advice from the technical support, forums, etc, however it still freezes. Things that I have tried:
      - Upgraded my graphic card driver to the latest (didn't work) then downgraded back to old version(still freeze), and then back again

      - Disabled wifi and used a network cable instead

      - Changed power management to run PC in maximum performance mode
      - Disabled CPU throttling

      - Run D3 in different settings including lowering all graphics and frame rates to lowest

      - Disabled suspected window services, reinstalled windows

      - Tried resetting modem

      - Disabled IPv6

    ...

    Can you please help me solve this since this issue has made the game become unplayable?
    What else can I do to solve the issue?
  • Hey ken and Mouth,

    I do have some additional steps for you both to try that may help out with the freezing. If not please post a DxDiag. Paste the DXdiag into the post, select and highlight everything you just pasted, and hit the "code" button (</>). That'll make the information much more readable.

    Please run Diablo III in 32-bit mode.

    • Let's set the Blizzard App to close when a game is running.
      1) On the Blizzard App click on the big Blizzard icon in the upper left corner.
      2) Then click on Settings from the dropdown menu that opens up.
      3) In the General preference tab, under the When I launch a game field, select Exit battle.net completely.
      4) Click on done and launch Diablo III


    • Run the computer in a selective startup mode.
  • Hey all,

    If the above steps did not help. please post a DxDiag and Diablo III Error Logs. Paste the DXdiag and Diablo III Error Logs into the post, select and highlight everything you just pasted, and hit the "code" button (</>). That'll make the information much more readable.
  • ken- I do see some Nvidia Share errors. See if disabling it helps. If that does not make a difference try disabling SLI when playing Diablo III.

    Brumal - Since you are seeing connection issue with the other games to this may be a different issue then what ken originally posted about. May take different steps to fix. I did see in the fires some Windows update errors. To be on the safe side make sure Windows is up to date. In addition to that try the connection steps here. If you do still see any issues run and post the results from a Pathping and Trace Route.

    Barry is you have not yet please try the steps here and then post the files requested.

    Kevin Do you see any freezing when the external monitor is not attached to the laptop?
  • Hey Kevin,

    Thank you for trying without the external monitor. The help find the cause of the freezing please post a DxDiag and Diablo III Error Logs. Paste the DXdiag and Diablo III Error Logs into the post, select and highlight everything you just pasted, and hit the "code" button (</>). That'll make the information much more readable.
  • Kevin System Model: MacBookPro13,3 I take it that you are using Bootcamp. I recommend installing the native Mac game client to see if you do get better performance.

    Nashetania There could be an issue with the sound driver. I do recommend reinstalling it to be on the safe side.

    I also see that the drivers for the video card are old. Make sure to update the drivers for the NVIDIA GeForce GTX 780.

    There are some options that the Windows 10 Creators update re-enabled that could cause this freezing. Make sure to disable these options.

    • Disable Game DVR
      1) Open the Start menu.
      2) Click Settings.
      3) Click Gaming.
      4) Select Game DVR from the sidebar.
      5) Toggle Record in the background while I’m playing a game to Off.


    Disable Game Bar
      1) Open the Start menu.
      2) Click Settings.
      3) Click Gaming.
      4) Select Game Bar from the sidebar.
      5) Toggle Record game clips and screenshots using Game Bar to Off.


    Disable Game Mode
      1) Open the Start menu.
      2) Click Settings.
      3) Click Gaming.
      4) Select Game Mode from the sidebar.
      5) Toggle Use Game MOde to Off.