30FPS on an X99 GTX1080 PC....really!!!

  • First off I will say that I have done absolutely everything to fix this issue of embarrassingly low FPS on this game and nothing all I see is excuses and a "shoo fly you bother me" attitude from blizzard staff regarding this issue!!!

    I'm running
    i7-6800k
    x99 msi mobo
    16gig dominator ram
    ASUS GTX1080
    2 ssd(of which d3 is on)

    and no the list of trouble shooting from all over the net:

    -low in game graphical settings
    -low audio settings
    -all drivers up to date
    -reinstall of D3 2 separate times and the battle net launcher 2 times
    -NVidia control panel setting optimization for all three "application controlled, best quality, and best performance"
    -editing the D3prefs file
    -setting CPU affinity
    -removing all startup apps
    -running fullscreen, windowed, and windowed fullscreen
    -running at different resolution i.e. 1920x1080, 1920x1440, or like my monitor 2560x1440 @ 144hz
    -malware and virus check
    -even to go as far as to pull apart every piece in my PC clean and reconnect

    AND NOTHING SO CAN WE PLEASE GET A RESPONSE BLIZZARD WE NEED THIS TO BE FIXED IF YOU EXPECT UP TO BUY THE NECROMANCER

    I for one will not be buying anything from blizzard if they cant even reply to what I'm sure is hundreds of people (blizzard customers) who are having this issue...
  • VikThor,

    Could you send in a DxDiag and MsInfo report to me at [email protected] Attn :Omrakos ?

    Instructions for generating the two reports are found here: https://us.battle.net/support/en/article/Obtaining-System-Files

    Reference this thread in your email please - https://us.battle.net/forums/en/d3/topic/20754356311