Screen Resolution in 2.5.0

  • Hello.

    I have iMac Retina 5K, 27-inch, Late 2015, native resolution is 5120x2880 pixels.
    And choose "Best for display" Resolution in macOS System Preference > Display.

    Until 2.4.3, Windowed (Fullscreen) game option respects macOS resolution settings.
    But in 2.5.0.44247, macOS resolution settings is disabled and turns dot-by-dot resolution while gameplay. (with very small and low-speed mouse-cursor)

    I found old-post: https://us.battle.net/forums/en/d3/topic/11915051681 and tried "defaults write com.blizzard.diablo3 DesktopModeIsDefault 1" and "defaults delete com.blizzard.diablo3 DesktopModeIsDefault". But these effect nothing.

    How do I avoid disabling macOS screen resolution settings with Windowed (Fullscreen) game option as in 2.4.3?
  • Hey all,

    Just to confirm, does changing the resolution in Diablo III not fix the issue? (i.e. does it come back every time you launch and exit the game?)

    Do you continue to experience the issue even if you were to change the resolution to something else, then change it back? We've gotten a handful of contacts on this since the patch, so we're trying to figure out what the cause might be.
  • Thanks for the follow up, folks. That does help narrow it down a bit. We still don't know if this is affecting everybody or just a few of you right now. There don't appear to be a ton of reports on this.

    It's possible that there's something corrupted in your settings or game data, or potentially something affecting the way the game interacts with your graphics drivers/OS. I want to start with the game data, since it appeared after a patch. We can reset these settings and repair the game. To do this, open up the Blizzard Application (aka Battle.net Application) and go to the Options menu above the news river. Choose Game Settings and press the Reset In-Game Options button for Diablo III.

    If that doesn't fix it, run a repair on the game.
  • Hey all,

    Thank you all for the update. Since the setting keep reverting after a restart I would like to get rid of the Diablo III setting folder. Open ~/Library/Application Support/Blizzard/ and then Delete the Diablo III folder. Empty the trash and then launch Diablo III.
  • Hey folks,

    I'm curious if there's some form of permissions error causing the settings to not stick. Can we try repairing the permissions for the game folders? It could also be a battle.net level issue. Let's repair the application support permissions while we're at it, then delete battle.net's cache file. Once that's all done follow the process to default game settings again, change your resolution, and see if it sticks.
  • Hey all!

    Just as an update we are currently investigating 3 different issues here:

    First is, CMD+Tab not working properly if you're playing in fullscreen. Next is, if you have the game in windows fullscreen it will change the resolution of the desktop while the game is running. Last, is the mini cursor or lack of the large cursor option from within the options for D3. I don't have a whole lot more information past this but we are looking into all 3 of these issues for possible fixes at this point. Drakuloth, myself or one of the other Blue posters will be posting updates as we get them. =)
  • Hey again all,

    Just wanted to get you guys some more updates on this. Our devs are pretty sure they located the problem and have what they think is a fix for this. The fix will take a client patch to implement, so it may be a bit before this stops on your end. Once we push it live I'll get you all some updates. In the mean time, thanks very much for the patience and reports on this!
  • Heya Amicus,

    The fix hasn't been released just yet. It'll take a larger 'client patch' (future game build) to release the fix. You can use some of the workarounds in this thread to see if it helps you out in the mean time, but ultimately it's going to be on us to get the fix in. Sorry for the inconvenience, and thanks for letting us know!