No sound in diablo 3

  • afternoon all. so just like the issues with heroes of the storm and starcraft 2 i have no sound in diablo 3

    i put in the "soundprovider=DSOUND" for those two games and it works but here in diablo 3 no dice.
  • Hey there Lumacman!

    Took a look over this and will want to start by making sure the volume is turned up in the Windows Volume Mixer. To get there right click the speaker icon in the task bar and go to Open Volume Mixer. If Diablo III is open then it should show up as an option to adjust the audio levels.

    From there I'd look into uninstalling any programs like MSI Nahimic that may have various audio settings. If you have any audio enhancement settings such as Dolby surround we'll want to disable those as well.

    Last thing for now is checking the playback device settings. For that we'll right click the speaker icon again and go to Playback Devices. Right click the default playback device and go to Properties followed by the Advanced tab. Let's test the default format set at 16 bit, 48000 Hz (DVD Quality) and 16 bit, 44100 (CD Quality).