Cursor Lag

  • My mouse cursor has been lagging ever since the BNET console was added, I think.
    I have a IMAC running 10.10.3 yosemite
    video -ATI Radeon HD 5750 1024 MB
    memory 4 GB 1333 MHz DDR3
    processor 2.8 GHz Intel Core i5

    No matter the resolution, windowed or not, bnet console open or not,
    the cursor just slowly follows the actual mouse movements
    The game used to run perfectly. What can I do to fix this?
  • Can you get me a bit more detail about your Mac?

      1. Click on the Apple Menu while holding down the Option key and select System Profiler (10.6.8) / System Information (10.7 and later).
      2. Copy the information from the following sections and paste them into your post. Please copy in the following order: Hardware Overview, Graphics, and Software. Do not include any serial numbers, hardware UUIDs, or account/login names or information in your post.


    Additionally, if you close the Battle.net App after launching does the issue go away?

      1. In the Battle.net App, click the Logo > Settings.
      2. Locate When I Launch a Game.
      3. Select Exit Battle.net completely from the dropdown.
      4. Click Done to finalize your changes.


    The Battle.net App should close when you launch Diablo III, which should free up system resources for the game. Give that a shot and let me know how it goes.
    ______________________________
    Technical Support: Monday-Friday, 12pm - 9pm Pacific Time
    How am I doing? || Support Agent Feedback ||