Sound laggs after skill spamming

  • Hello Blizzard, hello demonslayer.

    It's been a while since I played diablo, but with the new season, I wanted to give it a try.

    After the early 64-Bit chaos, it works quite well.
    But there is still a problem:

    After spamming the Blessed Hammer with my Crusader (haven't tried it with other characters) the sound lags really heavy because of the much hits.

    Here can you hear it really well.

    https://youtu.be/0FFPBNdW_Oo

    Many sounds are not played at all or are only played after a few seconds.

    Am I the only one with the problem?
    Is there a solution?

    What I tried:
    I changed the sound channels up and down.

    If It's necessary, here my specs:

    OS: Windows 8.1 64bit
    CPU: Intel i7-4790 @ 3,60 Ghz
    RAM: 16 GB
    GPU: Geforce GTX 970

    I really hope you can help me.
  • ShattixX,

    Please post your DXDIAG file (Not the MSInfo) so we can get more information about your computer.

    Here's a support article that will show you how to get the DXDIAG:

    Obtaining System Files

    Once you have the DXDIAG file, open it and copy/paste the entire file into your next reply.
    ______________________________________________________
    Customer Support Contact Information
  • ShattixX,

    In addition, go into your in-game options and under the sound options, what is you Sound Channels option currently set to?
    ______________________________________________________
    Customer Support Contact Information
  • Thank you all for the reports. I do have some steps I would like you all to test to see if there is an improvement. Please let us know if any of these steps help out.

    • Run the Diablo III repair tool.

    • Reset In-Game Options.
      1) Select the game in the Battle.net Desktop App and click Options .
      2) Click Game Settings.
      3) Click on Reset In-Game Options.
      4) Click Done and launch the game normally.


    • Lower the Sound Channels in Diablo III.
      1) In Diablo III go into options>Sound.
      2) Lower the Sound Channels setting and then press OK.


    • Change Speaker Setup and Default Device options in Diablo III.
      1) In Diablo III go into options>Sound.
      2) Make sure the Speaker Setup and Default Device options do correspond to the sound device you are using.
  • ShattixX,

    Your current sound driver is from 2013. Let's get that up to date to see if that helps any.

    Here's a link where that driver can be found: Realtek sound driver

    Once there, download the second one down the list. It should be labeled 64bits Vista, Windows7, Windows8, Windows8.1, Windows10 Driver only (Executable file).

    If updating the driver doesn't help, try lower the sound channel from medium to low.
    ______________________________________________________
    Customer Support Contact Information