Performance Issues with Running d3

  • OKay to start off, I played diablo 3 perfectly before, but now it has soo much issues Such as a a huge drop in Fps. In Neph Rifts and Greater Rifts in Multiplayer as soon as i enter the portal my fps goes from 60 down to 3. I dropped everything down to the lowest setting and it still remains to do it.
    Computer Specs are:
    AMD FX -6100 x6 @ 3.30
    20.0 GB of Ram
    2 Gig video card( Nvidia GeForce GT 610)
    Please if anyone knows how to fix this, i am willing to listen cause it sucks when your trying to hit a 90gr with 3 fps -.-
    Also if you need my Pref lmk ill post it!
  • Hello Jdbrennfleck,

    Let's see what we can do to stop this drop in FPS. I do have some steps for you to try that we have seen help out with drops in FPS before. If this still happens, please post a DxDiag.

    • Run the Diablo III repair tool.

    • Reset In-Game Options.
      1) Select the game in the Battle.net Desktop App and click Options .
      2) Click Game Settings.
      3) Click on Reset In-Game Options.
      4) Click Done and launch the game normally.


    • To be on the safe side make sure Windows and the drivers in the computer are up to date.

    Please run Diablo III in 32-bit mode.

    DxDiag:
      1) Press Windows Key + R.
      2) Type DxDiag and press Enter.
      3) In the DxDiag window, click Save All Information.
      4)Name the file "dxdiag" and click Save
      5) Paste the DXdiag into the post, select and highlight everything you just pasted, and hit the "code" button (</>). That'll make the information much more readable.
  • Jdbrennfleck -Glad to see that 32-bit helped out. Looking over the files it looks like that is going to be the best option.

    Jabba77- I do have some additional steps for you to try. You may want to keep Diablo III in 32-bit for now. If you do see an increase in the FPS after trying any of the steps then try 64-bit to see if the increase of FPS sticks.

    In the Windows power settings make sure they are set to High Performance.

    • Let's set the Battle.net App to close when a game is running.
      1) On the Battle.net App click on the big Battle.net icon in the upper left corner.
      2) Then click on Settings from the dropdown menu that opens up.
      3) In the General preference tab, under the When I launch a game field, select Exit battle.net completely.
      4) Click on done and launch Diablo III


    • Run the computer in a selective startup mode.

    • Please lower the graphic setting in Diablo III to see if there is a difference.

    Please make sure the video card settings are set back to the default settings.