Mouse pointer jumping around while moving on OS X 10.10.3

  • Ever since updating the game to 2.2.0 on OS X Yosemite 10.10.3, regardless of the game resolution, which I started at 5120x2880, the cursor jumps around whenever it's moving. It appears to be tracking two slightly offset positions, and the angle and distance of the offset seems to vary by where and how I move the cursor. It doesn't seem to be any sort of lag, as the cursor moves the instant I move my mouse. It just jumps every other frame between the one position and the other, and responds to one position or the other, depending on which was last visible.

    It may or may not have something to do with how I have three pointing devices attached: A MagicMouse, which I don't use for gaming, a Logitech G9x, which is what I'm using for the game, and a Magic Trackpad. This configuration never caused a problem before the recent update or 10.10.3.

    Do I need to post any troubleshooting logs?
  • kode54, if you remove the additional mice peripherals and cut back to one do you still experience the issue?

    Uxyz, what mouse are you experiencing the issue on, or does it have happen with other devices too if you substitute them out?

    Zamber, there were a few players who have reported issues with SmoothMouse. EliteLinus has posted a potential workaround here which may address the issue. Can you try this out and let us know how it goes?
    ______________________________
    Technical Support: Sunday-Thursday, 12pm - 9pm Pacific Time
    How am I doing? || Support Agent Feedback ||