Disconnects after a few minutes

  • D3 starts off working fine if I create a game, or join a public game, but after 2-8 minutes it just randomly disconnects, with no warning window. This is not a "The game connection has been lost" error, this error window does NOT pop up at all.

    Internet is working perfectly fine for any other game, program etc. so no network issues.
  • Hey there hakujo!

    So you can login normally. Start or even join a game properly .. but after a short time you get disconnected. Do you get booted out to the Hero screen? To the login screen? or out of the game completely? Each of these could mean a different cause so it is important to know which situation you might be seeing.

    I have some basic troubleshooting to tackle the most common causes so give these a shot but if it doesn't help, reply back with the answer to the above.

    Flush your DNS Settings.

    Try doing an extended power cycle on your system. Turn off all devices including the modem. Wait 20 minutes, turn on the modem, wait 5 minutes, turn on any network devices, wait 2 minutes, turn on your computer and try the game.

    You can try switching your DNS settings to use Google's free public DNS servers instead of your ISPs Servers.

    Let's reset the in game user options:
    1. Click the blue bnet icon on the bnet app.
    2. Choose settings, then game settings.
    3. Click the reset in game user options button under the correct game listing.
    4. Confirm the changes and close the window.

    Run the Scan and Repair tool.

    Try running your system in selective startup mode.