rx 480 grey screen when loading D3

  • I have been getting a grey screen when loading D3 from the battle.net launcher. I can hear the game coming on...but can only see a grey screen. I have the latest crimson update from AMD and I have disabled my integrated graphics. I checked the refresh rate on my display and with dxdiag and they are all set to 60 which my monitor is native at. As well as 1920x1080. I scanned the game file with the launcher to check if I was missing anything. I also never put in the two .dll files for a previous issue. I can play other titles: Skyrim with enhanced graphics mods, ark, overwatch, starcraft, civ 5 without issues.
  • Hey, NukedSeal!

    Can you please collect a new DXDIAG and post it here using the Code Blocks button in the posting options. Just make sure the full DXDIAG contents are between the code tags.
  • We have had reports that the newest Display Driver is having issues with the RX480. It looks like the new driver is causing issues in multiple games/applications.

    Can you use http://www.guru3d.com/files-details/display-driver-uninstaller-download.html to completely uninstall your current drivers and try the Crimson Edition 16.8.2 Hotfix drivers. If these do not work, you may want to try an older version of the AMD drivers to see if that helps.
  • Can you manually change the following line, located in your D3Prefs.txt file located in your Documents folder:

    <code>DisplayModeWindowMode "1"</code>

    This will open the game in windowed mode.

    After you do this, navigate to your Diablo 3 installation directory and right click on Diablo III.exe > Properties > Compatibility > Check "Disable display scaling on high DPI settings" > Check "Run this program as an administrator" > Apply

    Then try launching the game again.