Low FPS regardless of game settings

  • Here's my problem: I'm at a constant 38 to 37 fps regardless of what game settings i choose. I've set it to all low with low fx checked and i'll still be stuck at 38 to 37 fps. The only reason why i know my rig (laptop) can run it at a higher fps is because when i have a it in borderless windowed mode and i have something over top of the game i can see the fps shoot up to 150 to 160 fps. This only happens if i have something on top of the game like skype or file explorer. I have no idea why it does this but i do know that this problem is only for this game.
  • Hey Aebleskiver,

    Download the latest video driver and install it:
    http://www.geforce.com/drivers

    http://www.amd.com/drivers

    http://downloadcenter.intel.com/

    Close background programs that maybe conflicting with D3.

    Try resetting the in game options from the bnet app by opening the bnet app, login, select the D3, select the options drop down, game settings, then under Diablo III click reset in-game options, done. Then delete the D3 prefs file located in Documents>Diablo III . Relaunching the game client will recreate the file with default settings.

    If you continue having issues, please post your DxDiag and paste the contents of the Text document you just made into the post, select and highlight everything you just pasted, and hit the “code” button (</>). That’ll make the information much more readable.
  • Hey, Aebleskiver!

    Can you try disabling your AsusTek overlay software, Wacom tablet software and Teamviewer? After that, make sure your tablet is unplugged from your computer and see if that helps at all.
  • Hey again Aebleskiver,

    Can we try disabling the xbox dvr?
    There have been reports of the xbox dvr causing issues with our games since the windows 10 anniversary update and recommend to ensure this feature is disabled.
    Windows start > type XBox > open > login if prompted > click cog wheel (settings) > change game DVR slider to off

    Try setting your monitor refresh rate to 60hz.
    Right click your desktop and select display settings, click advanced display settings, display adapter properties, select the monitor tab, then choose 60hz refresh rate if possible.

    If vsync is checked, try unchecking it, if vsync is not checked, try checking it.
    Max forground FPS should be checked and set to 150 by default.

    Hope this helps!