BETA LOGIN AND CONNECTION ISSUES - 4/20

  • I am currently having problems logging in.

    The first time I tried to login the the Americas region at about 12:45 pm CDT, I successfully logged in after entering my credentials and authenticator code. I then backed out, changed my video settings to fullscreen windowed, and attempted to login again.

    After entering my credentials, I was not asked to enter my authenticator. I received the error "Player has been disconnected. (Error 3005).

    I tried again, and received the same error.

    I tried quitting all the way out of the game and restarting from the launcher. I still receive this error.

    I've made several additional login attempts, all of which result in the 3005 Error code.

    I decided to try logging into the Europe region instead. After clicking login, the login button greyed-out, but it did not appear to be logging me in.

    I went back to options and switched to Asia. Login button was still greyed-out.

    Back to options again and selected Americas. Login was still greyed out, and the dreaded Mac beach-ball appeared.

    After about 15 seconds, the game completely crashed. There was no crash reporter screen.

    I'd share the console log entries on the crash, but your forum won't allow me to paste in the 825 lines of debugging info.

    Subsequent to my first login, I have not been asked to enter my authenticator code.

    I am running the beta on a 2011 iMac.
  • Please don't post all cap thread titles. The forum for threads of this nature is: https://us.battle.net/d3/en/forum/3374140/